Compiling Non Fiction NOT WORKING!

I am using a Non fiction template and when I compile and export to Word (using a Mac), sections are missing. I thought it was because I had written some text directly in the folders rather than immediately start out with a sub-folder. But I changed that and it’s still happening. Under section type in Scrivener, I have everything set to “structure base” so I shouldn’t have to change the section types, right? I have watched all the videos but I cannot figure out what’s going on. Would so appreciate any help asap.

Hi.
Go to project settings and make sure all section types are set properly:
image

If everything seems right, meaning that the missing parts are of the same section type than some that compile alright, make sure all those documents are marked as included in compile…

That is easy to see in the compile panel:

If your section type being the right one and the documents being marked for inclusion it still doesn’t work, then you have an issue.

Thanks so much for the quick response. here’s what my project settings look like:

Does that look normal? It seems like each of my chapters and sections have been allotted to one of those sections but when I compile (and yes, everything is ticked), the compiled manuscript will have Chapter two but have no content, and then under Chapter Three will be the content for chapter two. Any ideas what could be happening??

Sorry see my response above

Yes. I understand perfectly.

First, that is not project settings. [EDIT] It wasn’t at the time I posted this…
That is the metadata panel. + Showing the section type of only your current document.

Not only that, but it is not set for a section type assigned per binder’s structure.

So, I will not go deep into the details at this point as there would be too much to say, but:

Find one chapter that compiles properly.
Look at this very panel you just screenshotted for this one chapter/document.

Set all your documents to that specific section type.

That should work.

I actually fixed the pic because I’d attached the wrong one initially. Does the new pic look typical for project setting? I will try the next thing you suggested. thank you!

ack. Okay, I see that you saw it.

I’ll save you some time:
Based on this new screenshot you just updated your post with, make all your documents be assigned to the “Headed Section” section type.

Or if you want to use the “per binder structure” properly, look at what you have for a setup…
A root file gets to be what you could call a “standalone”. Title + content.
It is nearly impossible to tell you how to fix your binder without seeing it, but reproduce what you see in this setup of yours.

The important thing here (because I’m trying to help you, not to make you confused) is that a document assigned to " Headed section" compiles with its title + body text.

Basically to get it to work, I had to change anything labelled “sub-heading” to “section” and then it worked. It sounds like I could have just gone into project settings and changed Level 1 files from “Headed section” to “Section” right? BUT, then I still had to go through a 400 page document to change font size and spacing. So many hours for one little export.

Each of my chapters/folders have a bunch of files within them, and each of those files have several files within them (which I guess is level 2?). If I used the non fiction template, I don’t get why it won’t export like that. Am I better off using a custom template? You’ve been so helpful. I can’t tell you how much I appreciate it!

This you could have done without.
The compiler could have done it for you.
Or perhaps it is rather that the compiler turned your formatting into what you didn’t want, in which case it only had to be told how else you wanted it.

Once you get the hang of the “per binder structure” section types assignation, you can either conform your project structure (or vice versa – the settings) or,
if you know you don’t have structural redundancies allowing for it to work properly, manually set the section type per document yourself in the metadata panel of the main interface.

BTW:
When clicking on an element in the Default type by structure panel (project settings), the corresponding files are highlighted in your binder. :wink:

. . . . . . . . . . . . . .
It takes some time to learn all of those concepts, but it is well worth it, trust me.

I think you may want to read the manual section about compile at this point.
It’d shed some light on what is what, and why things are as they are.

All great info! I will go back a reread the manual with this more hadn’t-on info under my belt. Thanks again!

1 Like

For future reference and others reading the thread, whenever you find yourself wanting to “go through a 400 page document” for a formatting change, something is wrong. The whole point of the Compile command is that you don’t need to make manual formatting changes.

2 Likes

I know right?! But I just couldn’t figure it out. I needed subheadings to be differentiated from sections, but if they were called subheadings, the document wouldn’t export properly.