Compiling struggles

I’m struggling to give Scrivenor a chance, because I really like the features designed to assist with the process of writing. But I am having no success in getting the compile process to produce a document that is usable for me. While I recognize that it is not intended to be a word processor, there should be some way of controlling what is produced by the compile process. I have no hesitation using another program for final formatting, but if Scrivener can’t compile something that has either some resemblance to the output I need, or at least some consistency, then I really can’t use it. I’m hoping I can get pointed to some controls that I have overlooked so that I can continue to evaluate the software for use with my team of writers.

We currently use MS Word for initial drafts of legal briefs, due to both its outlining feature (which I think Scrivener may be a good substitute for) and style sheets, which Scrivener doesn’t provide any support for. After producing drafts in Word, I use LibreOffice to compile a table of contents, table of authorities, and finally to produce a PDF (because it produces bookmarks that are useful, unlike Word). What I would like to do is use Scrivener to do the drafts, then either LO, or Word and LO to finalize the document. But I am unable to produce usable output for a number of reasons:

  1. the word “Text” appears before each section, and I can find no way to suppress it. Same with “Synopsis.” What’s that all about? Think I can’t tell what part I’m reading?
  2. numbering of sections and headings seems to follow no logical or predictable pattern that I can control. In some cases it almost seems psychotic. I don’t care what the numbering system is, so long as I can control it. But I can’t figure out how to get titles to be numbered, or how to get hierarchical numbering to work. And some headings I do not want numbered at all, but there seems to be no way to say number this but not that.
  3. I can’t find a way to stamp out Courier. That damn font is an abomination and should never be allowed to emanate from any computer for any purpose. I’ve changed formatting so everything is set to a reasonable font (I really don’t care what it is, so long as it is not Courier), and I have so set it for every level, even adding a few levels for good measure. No joy. Still the Courier emanates.
  4. page numbering doesn’t seem to have the ability to generate one series for front matter and a different series (including type of numbering) for the body.

There is a mention on the web site or in the manual that MMD is the format to use for stylesheet-compatible output. Maybe that would do what I want, but if so, there doesn’t seem to be any documentation of how to use it. Mind you, I have found pages and pages about it on the web, but nothing that gives the first clue how to use Scrivener to produce something it can process.

My preference is for stylesheets that allow me to define a style that I can change whenever my requirements change, so I have only one change to make to completely change everything in the document. I have read the criticism of stylesheets here, and don’t find them convincing. There is certainly no reason to be defensive about them. They are one way of doing things, and the direct-apply-formatting method is another. Lots of WordPerfect devotees feel the direct-format way is far superior. Who cares? I just want control over my output. If I can do it in Scrivener, fine. If I can produce output from Scrivener that will map to style sheets in another program, fine. If I can find any process that automates the formatting, fine. I just can’t afford to individually set the formatting of every paragraph in every document.

I hate having so many different issues in one post, as it makes it hard for anyone to help, but it is hard for me to know where to start. It is possible someone may have a solution that moots out some of my questions, which is fine. Since I can’t be sure what questions are the truly important ones, I put as much as I could think of in hopes that someone plucks out the juicy bits and sets me on a path to Scrivener-bliss.

Chuck

First, I would strongly recommend taking a look at our help materials. There is a whole chapter dedicated to Compile in the user manual (Help > Scrivener Manual) and three videos walking users through many aspects of Compile on our video tutorials page:

literatureandlatte.com/video.php

Scrivener provides complete control over the compile process, so it seems that you have not explored its full range of options. Make sure you click on “All Options” at the top of the Compile panel rather than just viewing the “Summary” view which only shows the most commonly-needed options to modify a particular compile preset.

Remember: The “Format As” pop-up button allows you to choose from a range of “pre-baked” compile settings. Each item in the “Format As” list is a saved compile preset that has a range of options turned on or off. It’s clear from your message that you are using one that applies a Courier font and suchlike, probably the “Standard Manuscript Format” preset or suchlike.

The first thing I would recommend, if you are not sure what is going on with Compile, is switching “Format As” to “Original”. This sets it up so that only the text of each document is compiled, and the formatting is not overridden in any way. This gives you a good starting point for setting up all of your own options if none of the pre-baked presets in “Format As” meet your requirements. (As Scrivener allows users to use any structure they want, it’s impossible to provide presets that will cover every possible structure that could be used, so the presets cover some common formatting requirements for common structures users may use.) You can then walk through the Compile options applying settings as you require.

I make no such assumption - they are, after all, entirely optional. If you don’t want them, just turn them off: in the “Formatting” pane of Compile, click on “Options…” and then deselect “Insert subtitles between text items”.

It’s certainly not “psychotic”, but its a little difficult to help without more information. Please see the “Placeholder Tags List…” in the Help menu for a list of tags you can use to control auto-numbering if the regular auto-numbering (available via Edit > Insert > Auto-Number) isn’t meeting your requirements. Many of the compile presets available in “Format As” have numbering set up in the title prefixes (editable in the “Formatting” pane under “Section Layout…”). For instance, the “Standard Manuscript Format” preset has a title prefix of “Chapter <$t>” set up there, which adds “Chapter One”, “Chapter Two” etc to the titles of folders. If you select “Original”, no numbering is added but you can add your own by editing the “Formatting” options (you can create your own Compile presets once you have all the options set up as you want).

As for having some headings not numbered, how you go about this is really up to you and depends on your structure. If these headings are part of documents on a different structural level to other documents that you do want numbered, or if they are of a different document type (e.g. if you want folders numbered but not text documents) then you can set this all up via the “Formatting” pane, creating different formatting settings for different document levels. Otherwise, you can always tell Scrivener not to apply any title prefixes to certain documents via the “Title Adjustments” pane.

Except, of course, that it is still the standard for many things, so many users require this. But again, you are clearly using an override format. In the “Formatting” pane, change the font. Or just turn off “Override text and notes formatting” altogether so that it exports using the same font and formatting you are using in the editor. (Switching to “Original”, as I say, gets rid of all options.)

Courier must be set somewhere. Please post a screenshot.

You should put the front matter in a separate folder, apart from the Draft, and select it in the “Contents” pane. (This allows you to have different front matter for different export formats.) See the “First Pages” pane of the “Header and Footer” section of the “Page Settings” pane in Compile to apply a different page numbering scheme to front matter. You could have Roman numerals for front matter, for instance.

Scrivener just provides the option to export to MultiMarkdown formats for users of MultiMarkdown; MultiMarkdown is something entirely separate to Scrivener. To learn about MultiMarkdown, you check out the MultiMarkdown web page:

fletcherpenney.net/multimarkdown/

I’m not sure what it’s after, though.

No one is being so defensive. The main problem with stylesheets is not philosophical but technical: the OS X text system has no provision for them, and implementing them is going to mean a whole new RTF export engine. Please do remember that Scrivener is developed by a sole programmer (me); we do not have the resources of Microsoft or Apple, and so certain things remain a little out of our reach for the time being. Style sheets are firmly on the list of possibilities for the future, though.

As I say, I recommend switching to “Original” for your Compile settings and then going through each pane in “All Options” mode, one-by-one, familiarising yourself with them and assigning the options you need. The “Formatting” pane is the most important, and it can take some experimentation, purely because it has to cater for so many possible binder structures, but it allows for quite a lot of flexibility, and the “Title Adjustments” pane (which appears when titles or title prefixes are set to be included in the “Formatting” pane) allows you to tweak things.

Best regards,
Keith

Ok. First, thank you for your detailed and speedy reply. I had tried to keep a long post from getting longer, but it was a mistake to leave out some details. Please don’t take my questions as criticism. There are some features I like a lot. But I’m asking about things I can’t figure out.

I had read the manual section on Compile, and watched all three videos. While there do seem to be a lot of controls, there is no map explaining every element that can be controlled, and where in the numerous places things can be set I need to go to set it. There is nothing in the manual about the words “Text” and “Synopsis” appearing in the output, or how to eliminate them (or that they are called “Subtitles”). I looked carefully for an answer to every question I had before I posted here, and did not post any question that is answered in the manual or in any message on this forum.

I have only ever used “All Options”. I have explored hundreds of options, and have made a lot of progress. By the 16th version of my test, I had several pages Compiling mostly correctly. I have never used a Preset. I have never selected Courier (shudder). In the Compile “All Options” Formatting window, the body section in every part was defaulted to Courier (yes, beginning with the “Manuscript” template). Even after I changed all of them to Times New Roman, some sections still remained Courier. Your assumption that I used a preset that uses Courier was mistaken.

Changing to Format As Original did get me closer to the required result, and did eliminate Courier, but left a number of issues.

That is helpful. Are these “subtitles” hard-coded, or are they editable somewhere?

This is interesting. For one, it is not at all clear to me from the manual what a prefix is, but the above quote implies that section numbering is done there, and not by applying a numbering format from the number/bullet style menu to the heading itself. I deleted all my headings formatted with numbering, created a hierarchical numbering “prefix”, then went to the “Title Adjustments” pane to stop numbering of paragraphs I don’t want numbered. All good, and now working as expected. Perhaps the definition and use of “Prefix” could be clarified in the manual?

While I don’t question what you say, I do have a finger-nails-on-the-blackboard response to Courier. It’s one of those remnants of my youth that I would like to disappear from all the Earth. I learned to type on a 1921 Underwood, and do not long for reminders of drafting appellate briefs on onion-skin with carbon paper in seven copies. Yuck. If I never see Courier again it will be too soon!

I followed your advice to start with the Formatting set to Original, which lost all the settings I had made over the dozen or so hours I’ve been fiddling with the formatting. Mind you, I’m trying to learn it, and without the lost settings I’m much closer to my goal, but it does prevent me from sending you a screen shot. If you want a copy of the ODT document from any of my earlier efforts, I’d be happy to provide it/them, though.

Testing all of this has led me to a suggestion for a new feature. It doesn’t seem easy to save Compile settings, and if a change is made, but then the user has to return to the document to change something before compiling, the change is lost. You might want to consider a “Save Compile Settings” button alongside Compile and Cancel. If it were me, I would also include “Save Settings As …”. Yes, I see that there is a multi-step way to do that, but it is multi-step.

This sounds promising. I already had the Front matter in its own folder. But when I dragged it outside the Draft folder, it does not appear in the menu of the Contents pane, so I can’t select it. “Current Selection” is available, though. Then I selected Page Settings > Header and Footer, but I don’t see any way to alter the numbering scheme to Roman numerals. Nor do I see a way to restart numbering with 1 for Draft.

I do understand what you say about stylesheets. I’m not sure that there would be much advantage in supporting them directly, but it would be great for me if there were a way to enable programs that support them to quickly apply them to sections of a Scrivener document. It is definitely not an absolute essential. If it were, WordPerfect would never have developed a dedicated following. But in my world, change is not the exception but the rule. Each court has its own requirements that have to be met, and I want that part divorced from the actual writing.

With your help, I am very close to being able to produce usable output, which will allow me to go to the next step of evaluating it as a writing tool, which is where I think it shines. I manage and edit other writers, and want to reduce their distraction by formatting questions and the like. It seems to me that Scrivener is a very good tool to develop critical thought, much more than just a writing tool. Word is a pretty good writing tool, despite the frequent criticism of it, but my early judgment of Scrivener is that it is much better at helping writers think. Testing that hypothesis is my goal, but I just need to be sure the outcome can be usable or the whole exercise is futile. Given that I’m about one issue from done with formatting, I’m optimistic.

Thanks again for all your help, Keith.
Chuck

In follow-up to that, I found the code to use for roman numerals, but the first try did not produce Roman numerals. I looked closer and saw that the manual had the code for Roman numerals preceded by a backslash, so I added that. That seemed to freeze Scrivener. Rather, it just never finished the Compile, but it let me click on other tasks, then cancel. When I opened the Compile window again, it showed the progress bar as if I had already clicked on the Compile button. When I removed the backslash, it finished the compile, but did not produce Roman numerals.

Going back to Contents, I see another problem. Not only does the <$p-r> not produce Roman numerals, the Page Settings appear to be global, as any change I make in Front matter remains in Draft, and vice versa.

Assuming this bit can be fixed, though, I believe I can put the Compiling aside and focus on the writing tools.

One more question: Is there any way to see the font selected in the Formatting pane? I see how to apply a font, but not how to determine what is already set.

This is on page 371 of the 2.3.1 version of the manual - I believe every option is covered in the manual, although admittedly that’s a lot of information to process, and as is always the case with manuals, it can sometimes be hard to find things when first starting out if you don’t know what to look for.

This means that you were, in fact, using a preset (what do you mean by “Manuscript template”, though? There is a “Standard manuscript format” preset, but no “Manuscript” project template - were you using the “Novel” or “General Nonfiction” templates perhaps)? The project templates that rename the “Draft” folder “Manuscript” by default have a Compile preset set up to use Courier. The Compile presets for these templates are set to use the same settings as “Standard Manuscript Format”. Given that most users start with these templates in order to write a novel (or book), they either want to export to a format for submission to publishers or for self-publishing. The default preset handles the former, using the still-standard Courier font but making it easy to switch to a different font (as explained in the “Making Changes” section of the info document at the top of the binder of these templates, which recommends using “Quick Font Override” to quickly change the font throughout).

No it wasn’t, since you started with a project template set up to use a Compile preset. Only the “Blank” project template isn’t set up to use a Compile preset out of the box. Each project template gives information about compiling in the info document provided at the top of the binder in each template.

Changing to Format As Original did get me closer to the required result, and did eliminate Courier, but left a number of issues.

They are hard coded, intended only for rough drafts, nothing more.

It’s up to you. You could add the numbering tag to the title of the document itself, but the downside of that is that it looks a little ungainly in the binder. So title prefixes allow you to add that sort of thing at the Compile stage rather than at the composition stage, and it also allows you to have different numbering for different formats if you want.

There’s already quite a lot about this on pages 364 and 365 of the current manual; I’m not sure what else can be done there, but I’m sure Ioa (who writes the manual) will consider any suggestions.

Along with Times New Roman and Arial, it is still the standard font for submission of novel manuscripts, apparently (although I’m sure that is changing in the electronic world), and it is still exclusively the font of Hollywood scripts, so I’m afraid we’re stuck with Courier for some time yet. Not that I have any particular fondness for it myself, but Scrivener does have to provide options that a large number of users want.

Sorry, I should have mentioned that; I hadn’t realised you had got close to what you were after - from your description I thought you were just playing and struggling with it.

This is already there. If you just want to save your current Compile settings without compiling, hold down the Option key and “Compile” changes to “Save”, which just saves the settings and closes the Compile panel (much the same as the Photoshop behaviour for editing web images). If you have a completed compile preset that you want to save for future use with other projects, select “Manage Compile Presets…” from the bottom of the “Format As” menu.

Look at the bottom of the “Contents” pane. There you will see a tick-box entitled “Add front matter”. If you tick that, you can then select a folder in the pop-up button next to it from anywhere in the project. This way you don’t have to have the front matter in the Draft folder and can select different front matter for different formats (for instance, it’s common to have slightly different front matter in e-books and paperbacks, tweaked to the formats).

That’s automatic if if you have different numbering on “First Pages” in the “Page Settings” pane.

This is the main problem - RTF supports stylesheets (albeit messily). RTF is Scrivener’s main export format (it’s .doc, .docx and .odt exporters are all piped through RTF first), but because Scrivener uses the standard OS X text system’s RTF export code, it doesn’t support all RTF features. The standard OS X RTF exporter doesn’t support images, headers and footers, footnotes, comments and much more, but I’ve managed to add all of those features to the RTF (and Word) export by post-processing the RTF. Stylesheets are something else altogether, and would really require me to write my own RTF parser from the ground up, which is why it is something that has been put off for the future (preferably for when I’m rich enough to hire another Mac programmer!).

Great to hear that the main aspect of Scrivener looks like it could suit your needs, and I think it’s definitely a good idea to put Compile through its paces while evaluating the software, as it is by far the most complicated part of the software, and not something you really want to have to learn when you are up against a deadline. We’ve done a lot to try to make Compile easier to use (believe it or not!) over the years, but it is necessarily a complex beast because of the flexibility Scrivener allows in organisation. Compile has to allow users creating any kind of document using any structure they wish to get as close as possible to almost any kind of output they want. The choice was between having something very limited that forced the user to do all of the formatting in an external word processor, or a Compile interface that allows you to tweak everything but which can seem overwhelming at first. Obviously, I took the later option!

You don’t need a backslash (whereabouts in the manual does it appear with a backslash? That may be a typo). Could you please tell me how to get it to freeze Scrivener - what did you enter where and what format were you exporting to? Obviously that sounds like a bug that will need fixing, but I can’t reproduce it - it works fine for me when I try that. Just to check, you were entering the <$p-r> in one of the header and footer fields in the “Page Settings” panel? What happens if you try the latest beta (available from the “Beta Testing” forum)? It all works fine for me so I’m wondering what we’re missing here.

You need to add the <$p-r> only to the “First Pages” header or footer. I’m not sure I’m following what you’re doing here, because the “Contents” pane doesn’t give any information about this sort of thing.

Because of space limitations, the font control isn’t shown in full in the Compile panel, but you can bring up the font panel (Cmd-T) to see which font is currently selected - click in the preview pane at the location you want to find out about.

All the best,
Keith

Thanks for the reply, Kevin. To keep this thread from getting excessively long, I’ll not quote much.

The manual that opens from the Scrivener help menu doesn’t have the information about the subtitles, but I’m glad a newer one does. As you say, sometimes it’s hard to find what you want even when it’s there. The manual I’m looking at also does not have the discussion of “prefix” you refer to later in your post. As there is no index, I’m not sure if the information is elsewhere in the manual. Maybe.

As for saving the Compile settings, you might consider some kind of clue to the user that the Option key allows saving without the compile.

Consider that you use “preset” to mean different things. When I said I never used a preset, I was referring to the formatting preset menu on the formatting tool bar, which is a collection of font characteristics as discussed in the manual. Apparently you also use it to refer to the collection of all formatting attributes for an entire project, which I referred to as a template, not because you named it that but because it seemed logical to call it that (even though what I normally think of as a template includes structure and sometimes content, and not just formatting). Using the terminology you use here, I started with the Manuscript preset. I could not find a way to eliminate all uses of Courier with it, but maybe I’ll just start a Blank template (which here is my definition of the word instead of yours, as that is what I’m trying to create—a starting point for writers that will produce the output I need). I can’t use the font override as I require different fonts for headers and footnotes than for the body.

While I found the way front matter outside Draft is included to be confusing and hard to work with, I did manage to get it included using your directions. And I got numbering restarting after the front matter. But I didn’t manage to get Roman numerals to work. Once I get this working, as I expect I will, then I’ll move on to the actual writing part of Scrivener. In Page Settings > Header and Footer I put “-<$p>-”, and in Page Settings > First Pages I put “-<$p-r>-”. What I get is Arabic numerals in both sections. When I used “<$p-r>” in First Pages, Scrivener just got stuck Compiling and never finished. My version of the Manual, v. 2.3-01a, has the backslash at page 391. Obviously I didn’t include the quote marks. I spent a few minutes trying to find a beta download, but I find no “Beta Testing” forum or any beta downloads. Maybe not looking in the right place.

Thanks again for all your help.
Chuck

Who’s Kevin? :slight_smile:

In verison 2.3.01a of the manual which you say you have, “prefix” and “suffix” are described on page 359; the part about subtitles is on page 364. They are both most certainly there, and have been ever since these features were introduced. All of this is under the section on Compile covering the “Formatting” pane of Compile, as you would expect.

It’s standard on the Mac for the Option key to change the behaviour of buttons and controls, but I will make a note to add a note to the button’s tooltip.

Well, there are only so many words you can use to describe features, and it would be silly to try to find a clumsy synonym just to avoid reusing a word that fits. So, we have:

• Project templates: when you create a new project, you choose a project template upon which to base it, or select “Blank” (which is what all project templates were created from).
• Document templates: you can create document templates within a project (e.g. character sheets and suchlike).
• Formatting presets - sets of formatting that have been saved and which can be applied to text.
• Compile presets - sets of Compile options that have been saved that can be reloaded later.

As I say, if you couldn’t eradicate Courier, then there was certainly Courier left somewhere in the “Formatting” pane. It is impossible for Scrivener to add Courier without there being a setting in Compile for it somewhere, since Courier is not a default font and the OS will never fall back on it.

I don’t really follow how that would be hard to work with, but I’m glad you’ve got that part working.

Wait, what word processor are you opening the file in? It should work fine in Word, but not all word processors will support the different numbering styles in RTF.

Thanks, that’s a typo and I’ve pointed it out to Ioa so that he can fix that for the next update. You shouldn’t add the backslash. It shouldn’t hang, though, and I can’t get it to hang at all in doing so, which is strange. Do you get a crash report at all?

The “Beta Testing” subforum is four forums beneath “Technical Support”. If you click on the “Scrivener for Mac OS X” forum, you will see the “Beta Testing” at the bottom. The “Beta Testing” forum is also listed and linked under the “Scrivener for Mac OS X” forum on the main forum page. The direct link to the download thread is:

viewforum.php?f=17

All the best,
Keith

Keith (not Kevin! ),

I’m compiling to .odt for LibreOffice. To test this, I compiled to docx, and the Roman numerals worked. Then I downloaded the beta, and they worked for LibreOffice, too. Great!

I don’t know if it survives in the newest copy, but if so, there are several other instances where it appears on the same page. Oddly, though, Acrobat doesn’t find them in a search for “<”.

Thanks, Keith (I mean Kevin ). I’ll provide feedback as I explore the other features of Scrivener. Probably more questions, too. But for today, I’m off of compiling and on to drafting!

Chuck