Compiling to mobi questions.

Couple of issues I’ve run into while compiling to mobi.

  1. Despite whatever font size I set in Scrivener, the converted mobi reduces it to ~12pt. Is there something I’m missing in the compile options?

  2. My folder titles appear roughly 60% of the way down from the top of the screen. Sort of seems strange to have the first page of each chapter feature five lines of text.

Any help would be appreciated.

Font size is not declared in the e-book. Rather, percentages are used to express deviations from the “body” size, which will remain undeclared (100%). Thus a chapter title slightly larger than the body text might be styled as “120%” in the code. If you want a larger font on your Kindle, there is a text setting in the reader software itself, as a personal setting, just like line-height, margin widths and sometimes the theme (non-e-ink models).

It is a convention that some people like. You can reduce or remove the spacing altogether in the Formatting pane. Click on the folder row and then above the mock editor area, right hand side, you’ll see a padding option. If there is nothing there, check the Section Layout... button and look for stray carriage returns (¶) in the prefix.

First off, thanks for the response.

I’m still confused on this one. I actually set the font size for Part One as much larger than the body text, but it appears smaller than said text when compiled. This might be in part due to using a different font for title/body (Typewriter and Times New Roman, respectively). The way I understand your response, it should be 120% the size of the body text. Any ideas?

I should have mentioned how Scrivener determines what “body text” means. Since this isn’t a dedicated thing, it simply takes the most common type of formatting in the book and declares that as “body”. This text is stripped of much of its formatting (in accordance with Amazon’s publishing guidelines) and then used to calculate all other sizes. So, what can happen if you’re doing very localised test that perhaps do not contain a lot of what we would call body text, you can get weird results because Scrivener is using some other type of text as the baseline. If you’re doing formatting tests, just dump a few thousand words of junk text into a file and add it to your compile list.

If that’s not the problem, let me know if there are any other things that could be potential peculiarities with content type in the book.

Sorry, Amber. I can’t make heads or tails out of what you’re trying to tell me here. I’ll try to demonstrate (though everything besides blah blah blah would be centered)…

        [size=150]Part One[/size]
        [size=150]I[/size]
        [size=85]Blah blah blah (beginning of chapter)[/size]

That’s what I’m going for, but all the text is displaying in the same size after compiling.

You are saying that all of the text is the same size, so perhaps I misread this earlier comment:

Did you mean that titles appear smaller than they do in Scrivener, or that titles are smaller than the body text? I read it as the latter, and that is what my prior answer was all about.

If all of the text is the same size, perhaps you have headings typed directly into the text editor, rather than having Scrivener generate and number them dynamically when you compile. Is this the case?

Heh, that’s exactly how I have it set up. The titles for each chapter are the name of each folder in the binder. I’m assuming, given the context, there’s a better way to be doing this.

My binder looks like this.

[Folder] Part One
[Subfolder] I
[Text] All the text from chapter I.
[Sunfolder] II
[Text] All the text from chapter II.

If you’re using the folder names to generate headings, that’s already the best approach, I’d say. So, in that case, you’re setting the size of the heading in the Formatting compile option pane, by clicking on “Folder Level 1” (parts), setting that up to look right in the editor below, then clicking on “Folder Level 2+” (chapter), setting that up likewise—and then compiling to Mobi… and all of this is the same font size when viewed in Previewer?

I can’t think of a reason for why that would happen, if that’s the approach you’re taking. As an experiment, have you tried compiling to PDF to see if the problem persists there?

Hmm, just compiled to PDF and it persists there. Must be some setting I’m missing in the compile options.

Solved it. Heh, all I needed to do was change to Text from Title for the folders and subfolders in Formatting.

Thanks for all your help, Amber. You’ve been replying to every question I’ve asked.

You’re welcome. :smiley: