Compiling with tables

I have a project that is simply a number of documents each of which contains two tables. The first has four rows and the second a single one row one column.

I have marked each document to Page Break Before but when I compile, there is a page break before each table i.e. before my second table.

Why is this happening and how can I stop it?

Thanks.

PS. I have tried “Stitch together” in the compile options but no luck.

If you turn on Format/Options/Show Invisibles do you see any page break characters in the document? If you do not know what one looks like, use the Edit/Insert/Page Break command to get an example. These can just be deleted if you do not need them.