Compose/ Paragraph Problems

I’ve downloaded the new 2.3 version and now I can’t change the compose background. I like to change textures and nothing is working. Also, when I am writing in Compose mode and revert to regular mode, I find random paragraphs moved an extra space down. This had happened since I’ve first bought Scrivener in 2010. Help?

A couple of questions for you: Are you using the backdrop feature, or are you setting a texture in the Compose preference pane, under Background? Both work fine for me, but there is one thing to know of. If a backdrop has been set, then the texture will be “beneath” the backdrop, which means you won’t see any changes if you try to set it. You have to remove the backdrop first with View/Composition Backdrop/No Backdrop. What OS version are you using?

Second question: could you clarify what you mean by “moved an extra space down”? Is this a purely visual thing? Are you using Page View in the standard editor? Are there extra characters inserted when you show invisible characters? A screenshot might help here.

First Answer: I usually use the Compose preference pane but it didn’t work so used the backdrop–didn’t work also. So I just installed it again and the backdrop now works, but the compose preference is still dead. I guess I could live with doing it the backdrop way, but the preference option gave me a chance to preview it before I chose my texture. I have Mac OS X 10.6.8

Second Answer: Hmmm, how can I explain this better, sorry for the confusion;
I write in compose:

When I’m done and revert back to page view, you can see the paragraph moves down a line. Never had this until the download after 2.0 .

I hope this helps and thank you for your quick response.

Compose background: Okay, given the example you’ve provided in the screenshot, backdrop is probably a better solution anyway. Textures are better for very small images that will be repeating over and over, like a texture of wood panelling, paper, or sandstone. Photographs and such take up much more memory and so are better only displayed once, which Backdrop does.

I’m not sure why textures aren’t working for you though. While everything I said above remains true, what should happen is your preference file gets a bit more bloated than it should be, and your software responsiveness may slow down a bit. If you could attach the graphic you are trying to select, that might help me figure it out. Like I say I did a few tests before answering this and had no problems assigning a texture. I was however using very small PNG files for my tests.

The spacing issue: The only thing I can think of offhand that might cause what you are seeing is a stray tab on the end of the line. If there is a tab and no tab stop, the text engine will jump to the next line like that. However it should show up the same way in Composition mode as well, so it’s odd, but Page View does do a little more interpretation than the other editor modes. If you enable invisibles (in the Format/Options menu), do you see extra characters around this area, when compared to other paragraphs in the document?

No extra characters and the tabs are correctly in line. The only thing that’s a bummer with this problem is when I do finish my novel and compile, I’ll have to go through each page to make sure the skipped line isn’t there.

If you turn off Page View mode temporarily, does the space go away?

Nah, it’s still the same. :frowning: It’s like my SCRIV has a mind of its own.

Could you send me a sample that will demonstrate this? Use File/Back Up/Back Up To... with the Zip compression option turned on, then attach to an e-mail sent to AT literatureandlatte DOT com, attn: Ioa.

It’s been over a day since I’ve logged onto my computer, so sorry for not getting back more promptly. NOW, logged onto SCRIV this morning and low and behold all of my random spaces are still spaces…but now when I go into compose mode it also has the same spaces. I seems that both page view and compose are now congruent with one another. I went through all 28 chapters and this is what I have:

But I don’t want to celebrate prematurely until I write another chapter and see if it happens again. I’ll give you an update tomorrow, that should give me enough time for a chapter or two. :confused: Fingers crossed. Don’t want to send you a sample if the problem has fixed itself, but if you still want it I’d be more then glad to do so.

Your help has been amazing, so far thanks so much AmberV