Compose view prevents macOS "Look Up" function

Hi, not sure if this has been reported, but I can normally three-finger-tap on my trackpad over a word word in my document and engage the “look up” feature of macOS, but this doesn’t work for me in Compose mode.


Funnily I wasn’t even aware that this option did exist. But then, I just retired m old MacBook from '06 which didn’t had this option anyway.
Now, I could use it, but not in compose view; so yes, that seems like an omission.

That’s a known problem with the gesture in this version, it will be fixed in an upcoming major upgrade. Currently it works using the Ctrl-Cmd-D invocation instead, though.

I’ve also had this problem since the last major update. The Ctrl-Cmd-D invocation doesn’t work in composition mode for me (does work in normal view), but I really look forward to the next big upgrade!

I should say it should be fixed. :slight_smile: Who really knows, it works on my computer in a test build, but so does Ctrl-Cmd-D in the current stable build. As has been noted on the forum before, the reliability of this service is spotty at best, and can even vary between different programs.

Check  > System Preferences > Trackpad > Point & Click > Look up & data detectors > Force Click with one finger / Tap with three fingers.

Force Click doesn’t work in Scrivener (as a 32-bit app), but three-finger tap should work (in composition mode) if set in system preferences.

Thanks for the reply. Just wanted to report that Ctrl+Cmd+D is not working in compose mode either.

For the records: just today I installed macOS 10.12.3 Beta 4 because - well, Apple pretty much broke PDF viewing, annotating, OCRing and so on in 10.12.2 and since I need to do my taxes and ALL the receipts, invoices, whatevers are in PDF… anyway, apart from getting new gray hair while searching for a fix, I can now work on my evil tax evasion scheme.

More important: suddenly the three finger tap works as well. Maybe 10.12.2 was really, really, really broken…
NOTE: OK, it only works in compose view when Scrivener is in regular windows mode, not full-screen.

Care to elaborate :smiley: ?

The 10.12.2 update broke my entire Mac. I just got back from wasting a day reinstalling and restoring thanks to it. I’ll be glad when I can leave my main system a year or so behind Apple’s bug curve again.

Only with great care. :wink:

And miss all the fun stuff? :smiling_imp:

Eh, you do know it is possible to die from curiosity, right? Just mentioning it :wink: