Composition mode/Dual Screen/Control Panel

I use a Macbook Pro 13in with a 24in monitor placed behind and above the laptop screen. The laptop screen is the main screen; the monitor is the secondary. In other words, the OS X dock appears on the laptop screen and the screens are stacked one above the other.

With the Scrivener app running on the monitor, I enter into Composition mode. This triggers the Control Panel briefly on the monitor, i.e. it fades in and then out.

Now when I move the mouse to the bottom of the monitor, I expect to see the Control Panel. However, since it’s a dual screen configuration, the mouse slides into the laptop screen below, without triggering the Control Panel. Sliding the mouse further down towards the dock does nothing, as expected.

If Scrivener is opened on the laptop screen, then the Control Panel appears properly. If the screens are arranged in the System->Displays preferences to be side by side, the Control Panel appears as expected. I suspect that my (admittedly odd) configuration hasn’t been tested, as I can’t find any references in the forum to such a problem.

OS X El Capitan, 10.11.6
Scrivener 2.8 (26295)
Macbook Pro (13-inch, Mid 2012)

After the upgrade to version 3, this issue is sorted out. The Control Panel appears as expected.

Great, thanks for the update - glad it’s fixed!

Hello there, I update this post because with almost the same config (macbook pro 13" and 27" monitor), I got the same problem when in composition mode.
The screen is on the left of the monitor, and Scrivener/Composition mode can be on the 1st or the 2nd monitor, still the problem : the control panel appears few seconds, then disappears, and I can’t show it again… =(

macOS Mojave, Scrivener up to date !

Any idea ? Thanks.a lot !

EDIT : okay, this Control Panel “bug” seems to be an auto-solving one : I continued my researchs on the forum, and just saw a guy with an other question about the Composition Mode who talked about the Mission Control option “Displays have separate spaces”. I tried to uncheck the box, my problem was solved but the behavior wasn’t what I expected, so I checked the box again, and… It works now. :mrgreen:

I was not able to reproduce this problem. I tried all three arrangements. Laptop to the left, below and to the right of the monitor. Works for me.