Composition Mode Inspector ignores Inspector appearance preference

Environment:
MacBook Air 11.6" 2015, MacOS Mojave 10.14.6 (w/latest security update), Scrivener 3.1.5

Procedure:
(note that I can start from either Light Mode or Dark Mode to see this bug.)

  • In Scrivener, load a Dark theme in which Preferences->Appearance->Composition Mode->Options “Inspector uses dark appearance” is set to ON (ticked).
  • Quit and restart Scrivener.
  • Enter composition mode.
  • Display the Inspector. Confirm that Composition Mode Inspector has dark appearance.
  • Exit Composition Mode.
  • Load a Light theme in which Preferences->Appearance->Composition Mode->Options “Inspector uses dark appearance” is set to OFF (unticked).
  • Enter composition mode.
  • Display the Inspector.

Expected result:
Inspector displays with light appearance.

Actual result:
Inspector displays with dark appearance.

Workaround:
In Preferences->Appearance->Composition Mode->Options toggle “Inspector uses dark appearance” to ON (ticked) then back to OFF (unticked). The Inspector changes appearance to Light.