Composition mode not available

I was working on creating a Scrivener template. I added an image as background in project settings, went into composition more and the image showed fine. I exported the template, played a bit around with it and then clicked on the composition mode icon in the toolbar again. Nothing.
And the option in the menu is even greyed out.

Any ideas?
Bildschirmfoto 2022-09-03 um 06.15.24


EDIT: Ignore what I wrote below as I was clearly wrong. Apologies.

That option is only available if a document from the draft folder is loaded in the editor. Are you sure you didn’t have something from the reference folder or elsewhere open at the time?

Composition mode is available from almost every context (where keyboard focus is) in the project window, and is not limited to only working on text items found within the draft folder.

Really, it is unusual for it to be disabled at all, outside of when working within modal dialogues like Compile. It would help to know what state the project window is in, where the cursor is, and whether changing anything about it causes any changes.

1 Like

Could it be that the background image is missing from that exported template (or theme?), and that, for some reason, composition mode is dependent of it ?

Why do you say “template”, and not “theme” ?

Apologies for my error. :frowning_face: And gracias for the gentle correction. :blush:

Because I created a project template according to my universities formatting guidelines, not a theme.

Composition mode still doesn’t work in the project where the image is definitely accessible.

I hoped things would settle after I’ve closed all the projects and rebootet the laptop. Didn’t happen, sadly. I’ll now try to going through the things to try that @AmberV suggested.

Problem solved, somewhat.
In the end, it looks like @sobs was right.

I’m only able to enter compositon mode, when I’m on a document in the draft folder.

Thank you @sobs

1 Like

Beg to disagree. If I’m in a synopsis, the outline view, or corkboard view, entering Composition mode displays nothing but a background.

The composition mode editor only shows the text of the focussed document, regardless of the context from which you selected it—so if document A is selected in the outliner, switching to composition mode will load document A’s text in the composition mode editor, not the synopsis or whatever else is visible in the outliner. If document A doesn’t yet have any text, the composition mode editor will be blank, but like loading an empty document in the main editor, it’s ready for text to be added. If the outliner or corkboard is displaying a container’s contents with nothing selected, the loaded container is the implicit selection and that item’s text will display in composition mode (just as you’d see that container’s title, synopsis, and other metadata in the inspector in the main window).

There is a limitation in that composition mode can only display text documents; could that have been what you encountered? Text documents from anywhere within the binder should be able to load in composition mode, but PDFs, images, etc. cannot be opened, and in the case where one of those file types was selected, the Enter Composition Mode menu option would be disabled as in your earlier screenshot.

Yes, that might have been the case. Classic PEBKAC.

Thank you,


If by text document you include folders, not just files, that may be true, and I happened to be selecting empty containers when I tested this earlier.

Glad the issue is resolved for you. :partying_face:

1 Like

Yes, I meant text items including folders, since in Scrivener either can contain text; this is as opposed to items like imported webpages, media files, PDFs, and so on. These items can be viewed in Scrivener’s editor but not edited there, and they won’t load in composition mode.