Computer Crash. Backups gone.

Hey there. Was writing earlier this evening and my computer froze. This happens from time to time, so I clicked it off and on again, then went and did something else for a while. Came back to my Scrivener project only to find that it’s reverted to the morning of the 14th. I checked the backups, and the latest backup is the morning of the 14th.

The only thing I can think is that I haven’t closed the file in three days, so maybe it hasn’t backed up between then and now?

I’m pulling my hair out here. Any suggestions would be appreciated.

Check your backup settings, in Tools -> Options, I think. If you have it set to “Backup on project close” and haven’t closed the project in three days, then you are probably in trouble. But what happens if you simply open the project again?

The live project (the one you’re working on) reverting seems strange. Did you use File->Save As to create a backup copy? It’s possible that the copy you made as a backup that way contains your more recent work (Save As closes the original and opens the new copy–you might have continued work there accidentally), but you opened the original when you restarted your computer.

I’ve always just used the auto-save and backup features as my fallbacks, so no I didn’t have a “save as” separate file. I managed to find the RTF files of two of the scenes I’ve written, but the RTF file for everything I did last night (the scene I was writing when it crashed) is just an empty file.

Auto-save doesn’t do a backup, it just saves the current work in progress. If your computer crashes while the project is open, it gets corrupted because of the way Windows manages things.

To get actual backups, from the main toolbar go to Tools>Options>Backup and adjust the settings. Note that after check-marking ‘Turn on automatic backups’ you also have to choose the actions that you want it to take before it will do anything. Be sure to click on ‘Apply’ after making your selections and before closing the popup window, I hit ‘Ctrl-S’ for a manual save at regular intervals so I always have a near-current backup. See screenshot:

By any chance, did you have the latest Windows version 1.9.9 installed and did you enable “Use safe document saving mechanism?”

If not, you should upgrade to 1.9.9 and enable that feature. FYI, it may have saved your missing scene.

“We have introduced the safer Windows Scrivener 3.0 save mechanism as an option for saving Scrivener project files in version 1.9.9 (not enabled by default). You can switch this on/off via the menu Tools -> Options… then check the checkbox titled: Use safe document saving mechanism. Checking this option protects against losing data during a system crash such as a power failure, unexpected Windows shutdown etc. You can switch back and forth between this new save mechanism and the old. For more detailed information about the differences between these two save options go ahead and change the setting and read the dialog that displays.”