Confused about "Treat compile group as complete manuscript"

Hello:

I’m trying to export just selected chapters, with proper chapter numbering. This isn’t working as I expect, at least on RC12. I’m not sure if the problem is my lack of knowledge or a bug.

What I think I should do:

  1. Select the target chapters in the binder
  2. Start Compile
  3. Either pick “Current Selection” or pick “Manuscript” and use filters to select the current selection
  4. Make sure “Treat compile group as complete manuscript” is not set
  5. Run compile

This doesn’t work. I get chapters starting with 1. Half the time I don’t get the scenes, just the chapter headings. I don’t even get an option for “Treat compile group as complete manuscript” unless I go into the Compile menu and pick some subset of the manuscript. But, if I do that, I never get anything from the scenes, just chapter titles - and they’re still wrong!

The only way I ever even see “Treat compile group as complete manuscript” is if I pick some subset of the Manuscript in the Compile menu. I can’t see any way to pick multiple chapters in there, and it seems like the wrong place to be selecting them anyway (I’d much rather do it in the Binder, not in some popup menu).

So, is this a bug? Or am I doing this wrong? It seems like exactly the right solution, except it’s not. For now, I can obviously export the whole thing, then chop out chapters, but that’s clunky and time-consuming (given that I’m sending three chapters at a time to reviewers and I have 66 chapters in my current work - that’s a lot of extra exporting and deleting).

Thanks for your help!

Yes, all of your questions are answered in the user manual, under Compile Group Options, in §23.4.1. This particular option only appears when changing the top level group by design (and as noted in the manual, it’s more the kind of thing you would do if you had a trilogy in the Draft folder and only wanted to work on one at a time). It is not a setting that is applicable to other settings, like filters or selections of items.

That’s just how it is. I’ve never asked, but it may have something to do with how it would be a lot more difficult to number a potentially wildly non-linear selection of items, thanks to everything filters and selections can do. It’s one thing to count up the tokens preceding the start point and then go from there, and quite another to end up with “Chapter 21 … Chapter 2 … Chapter 57” in that order, because that’s how your collection is set up and everything but those three are filtered out on account of a label setting.

I know that isn’t specifically what you’re asking for here, but the mechanism itself by which you are doing what you are doing would need to be capable of the above.

That’s interesting, because when I’ve searched questions of the form “how do I start with a chapter other than one?”, that’s the answer - use “Treat compile group as complete manuscript”. But apparently I can’t actually do that. Even manually setting a starting number would be a workaround, but I haven’t seen a way to do that.

I did check the manual, but it refers repeatedly to a “Draft” folder, which isn’t even something that I have as an option, so my assumption was that the manual was out of sync with the current RC.

Thanks!

It works if you select one chapter with the dropdown, which is probably what most people are wanting to do, then yes, the answer is sufficient.

It still is incomplete in a few places (compile settings mainly, as well some detailing here and there), but not on something as fundamental as this. Every project has a Draft folder. It is impossible for there to not be one since it cannot be deleted. It is one of the three core root folders (see §6.2 in the introduction), along with Research and Trash, that are always going to be there at the top level, somewhere. You may want to flip to the tip box on page 69, aimed at those wondering whether their project has one.

I see that it’s clarified on page 69. That makes the rest of the manual a little confusing if you’re not reading it cover to cover, but I get the intention.