Contents list in Kindle file

I’m working on formatting a book of short stories. Everything is fine-ish, except for one thing: I’ve put the titles of the stories on their own page, by making each a separate file, and the HTML contents list is including these titles, like this:

Fire title
Water title

(where the first two stories are called Fire and Water - the file with the title is called Fire title, and the file with the story is called Fire).

How can I solve this?


If I were going to do this, I would make the titles into folders and name them with the name I wanted which, in your case, is “Fire”, “Water”, etc. Then I would check the Title checkbox on the compile of these folders and set Title Settings with the Chapter prefix and suffix I wanted. Then I would change the separator for “folder to text document” transitions (the picture is a folder above a text document) to “Page break before”. I might be wrong, but I think this will do what you want.

The only way I got comfortable with Compile was trying things just like this. And I’m still learning. Good luck.

One solution would be to create your own table of contents page. To do so, create a new document for the contents (either at the top of the Draft folder or in the front matter folder). Then, select the documents in the binder that you want included in the contents and go to Edit > Copy Special > Copy Documents as Scrivener. Then paste into the document you created.

Then, in the Layout pane of Compile, make sure that the table of contents title matches that of your contents document (or just name your contents document “Contents”, which is the default). If Scrivener finds a document matching the name given in the “HTML table of contents title” setting, it will use that document for the table of contents instead of generating one automatically - that way you can take complete control of your contents page.

Hope that helps.

All the best,

That worked, Keith, thanks very much. And thanks for your help too, jraven - I actually tried Keith’s suggestion first and it worked fine, so didn’t actually try yours, though may in the future.