Contents Page Issue

Hi I have recently started using Scrivener and so far it has been an absolute pleasure.

For some reason whenever I create a contents page for any of my books (learning to make an e-book for kindle) I have some issues.

I am using the .mobi setting and compiling everything as described online.

However I always seem to get more than one of the same title of each section of my book. Some sections are repeated in the contents up to four times whilst other sections are repeated once or twice. After a bit of looking around it seems that the number of pages I go onto contributes to another line of it appearing in my contents page (if that makes any sense). I have tried putting the sections into folders but this has not fixed the problem either.

I would be grateful if anyone could help me out with this issue.

Cheers :slight_smile:

It sounds to me as though you may have stray page breaks in your work—perhaps it was imported from a word processor which puts page breaks into your document as it would insert characters. The easiest way to clean up stray page breaks is to search for them. To this you’ll want to get an example of this page break character. Use the [b]Edit/Insert/Page Break[/b] menu command with the cursor at the very beginning of a paragraph.

You should see it jump down a line (and if you have Show Invisibles enabled, you’ll see a little “bar” icon). Press [b]Shift-LeftArrow[/b] to select the page break character and use [b]Edit/Find/Use Selection for Find[/b].

It would probably be easiest to load your entire book as a Scrivenings session by clicking on the Draft folder. In the main editor, simply hit [b]Cmd-G[/b] to find the next occurrence of a page break character (which you’ve transparently loaded into the find panel with that prior menu command). Delete these as you encounter them (unless of course you do want a section break there).

If you don’t have stray page breaks characters, then you have have a problem with your compile settings or with the “Page Break Before” checkboxes, assuming by “pages” you mean individual documents. For example it is possible to tell the compiler to insert a section break in between each text document. In cases where one writes one document per chapter, that may be desirable.

The easiest way to view all of the inspector checkboxes at once is in the Contents compile option pane, which includes this option as a visible column. Just quickly scroll down and make sure none of these are checked off for page breaks unless they should be.

Thank you so much AmberV your first solution worked perfectly for me!

As you suspected I did have page breaks in my writing and your method helped me find them all. Thank you for your speedy reply and clear instructions. I feel like I have learned a lot!

I now have a beautiful contents page! :mrgreen: