Continued problem with bullets in 2.9.0.21

I am still having a problem with bullets in the most recent release candidate version. I am using Scrivener Beta 2.9.0.21 on Windows 10 Home Edition, 64 bit.

Basically, once I start a bulleted list, I can’t get out of it. Whether I try to backspace or use the drop-down list to choose “no bullet,” it continues to bullet lines below the list, slightly to the left of the first row of bullets. Moreover, when I click away from that document and then click back, the unbulleted lines above the list are now bulleted. A couple of screenshots will illustrate:

Before clicking away:

After clicking away and clicking back:

These screenshots were created with 2.9.0.20, but I’m experiencing the same problem with the release candidate I just downloaded.

…have you tried just hitting an extra return, after the last item you want bulleted?

Bullets in Scrivener do work a little differently than some other editors, it’s true. Usually though this part is consistent.

Good fortune :kiteemoji:

:frowning:

Here’s from a prior note describing how bullets work, apart from the hit-return-twice-to-leave-bulleting above, which again, is normal for bullet features in other software.

Some of these following are unusual, but as stated, they do work, and work nicely:

Sorry, but that list is unhelpful in the worst way.

Scrivener does (well, it should) work like other word processors. In fact, the very first item in your list is wrong; Scrivener does, in fact, change the bullet type when you tab to indent. Also, I’m not copying an old list every time I want to make a new list.

And hitting backspace to end a bulleted list is how Scrivener has always worked for me (haven’t done the same check OP has done on 20 and 21). But there’s no excuse for the bullet button not removing a bullet from the current line.

Is it. Have a look here, @bt:

It will change style on indents – but only after you’ve actually chosen a style for that indent.

That’s what my list says.
And how Scrivener acts, at Beta 21, at least here.
Win10 latest everything.
I still haven’t figured out why you thought a crotchety-face was an explicit first reply…

Bullets change. This original post was about bullets. I didn’t consider numbers. I’ll concede. But… bullets absolutely do change with tab.

Well, absolutely??

But cheers…

And sorry, would be clearer if I’d raised the magnification or font size a bit.

Or flipped the square and closed dot for third and fourth levels.

Yes. I get the same result whether I hit an extra return, hit backspace, or choose “None” from the drop down list.

Incidentally, this is something that works fine on my 1.9.9 release (there were other issues which have been corrected, but it wasn’t trying to extend a list beyond where I wanted it to go).

Well, I got rid of the bullet problem by hitting the “default” button in Options. So now it seems to be working as expected.

It does seem a bit weird that with a fresh install in a new location, there was a problem that had somehow held over from previous installations. It seems that previous uninstalls were less than clean. Don’t know if it has to do with me having Scrivener 1.9.9 elsewhere. (Do they share a common folder in the “App Data” directory?)

There is one final problem–an error message I’m getting on startup. I’ll put it here in case it’s related to the continuation of the bullet problem prior to going back to defaults. For reference, I had installed previous betas in a folder in my “My Documents” folder. Beta 22 I installed to the default location. It’s telling me that I’m running it from a different location than it thinks I have it installed in. (The location it thinks I have it installed in no longer exists.)

Not sure if this has been reported elsewhere yet as I have been away from the forum for a while. Bullets in general work fine on R21/22 for me, The problem I have is when I am in the middle of a bulleted list and want to add a new bullet above the current one, I position the cursor at the beginning of the text and hit Enter and nothing happens. If I am in the middle of the text, it produces a new bullet below and breaks the text where you would expect it to. And if I am at the end of the text and hit Enter, it creates a new bullet below properly and as expected. But if I am on the first line, I do not have that work around, and have to either move the cursor over to the right one character, then hit Enter and adjust text accordingly, or go to a blank line above and hit the icon to add a new bullet. But if I had adjusted the formatting below, then the new bullet is of different formatting (indent, hang, etc.)

Therefore, the way it should work is if I am at a bullet at beginning of text, that it creates and inserts a new blank bulleted line.

Can confirm that, can’t hit enter to create a new bullet ‘before’ a bullet; I have to start writing text and then hit enter to split the bullet.

Also a bug I hate reproducing:
You cannot paste into an existing bullet. If you paste text anywhere inside a bullet, it creates a new bullet instead. Even if you paste into an empty bullet.
Hitting undo after copy pasting inside a bullet will often mess up the styles for that list as well (it’ll go back to solid bullet instead of hollow bullet, for example).

I’ve also listed other problems with lists and bullets that continue with RC2 / Beta 22 here:

[url]https://forum.literatureandlatte.com/t/lh4050-lh4233-continued-problems-with-lists-bullets-moving-up-down-and-changing-indent-rc1/46823/2]