Control TOC formatting for print output

I’m creating a PDF to go to print (Createspace) and want to include a table of contents.

Ideally I’d like to use the “Create TOC” command under the ‘Edit’ tab - and I’ve done this successfully after consulting both the manual and Ed Ditto’s book. But, the output adds the words “Chapter ***” in front of the actual name of each chapter. This makes the lines too long and the whole thing breaks down.

How do I get rid of the “Chapter ***” bit. I figure it must be controlled under the compile function. Is this being set by the “Formatting / Section Layout” control? I can’t understand why it would be. I’ve looked all over and simply can’t find a way to change this behaviour.

Any ideas?

I know I could create a manual TOC, but I’d like to get the hang of the automated way if at all possible.

Document links such as used in the table of contents are updated during compile to match the title as generated for the document based on the Formatting settings. So if a document has a “Chapter” prefix added (by the “Section Layout”), that is also added to the text of Scrivener links with that title.

Often this is what you want–if you’ve titled your documents for internal use but are replacing all of that with “Chapter One” and so on during compile, you want your table of contents to reflect that and use the compile name. You can change the behaviour for individual documents, Front Matter documents, or all documents in the “Title Adjustments” pane. In your case you probably just want to deselect “Update titles in document links with prefix and suffix settings”. If you use links elsewhere and want them updated there but not in the Table of Contents you could exclude the ToC specifically by selecting it from the gear menu or excluding all Front Matter documents, assuming the ToC is being added as front matter in the Contents pane.

You could also just remove the links entirely from the ToC document in the editor if you’re not needing them as internal links in the compiled document. Since you mention this is for print, they won’t be doing anything in the final output.

Thanks for the help - very useful and solved the issue for me.