Controling emoji size in compile

Hi all,

I just started using Scrivener. So far I’m really happy with my software choice. Obviously I’m still in that zone where you think something should be possible, you try to figure it out but can’t, you curse the software… only to find out it was really easy, you just had to click that one little button :blush:

I’m hoping that my current problem belongs in that category. I’m at the early stages of a novel, but it’s already clear that I will need emoji in the final version. I have a couple of instances where I replicate text messaging, which means using emoji. My problem is that they appear too large in the output - see attached screenshot.

As you can see, the first two lines have a regular line spacing. But the third line has a larger spacing, because of the emoticon size. That disrupts the whole layout.

I’m using styles for the paragraphs. The styles have been set to a certain font + size in the compile interface. But since the emoji use a different font, I don’t know how to control them in the compiled version, because afaik you can only pick one font per style in compile.

I can control the emoji size in the editor on a case by case basis: select, pick correct font size, repeat. But that formatting is lost in compile.

Any ideas?

P.S.: sorry, I’m not a native English speaker, so “pardon my French” (actually Dutch, but ok).

On thing you could do is use a character style for emojis:

  1. Select an emoji in the editor.

  2. Go to Format > Style > New Style from Selection…

  3. Name the style “Emoji”, choose to save character attributes only, and only tick “Include font size”.

Use the “Emoji” style for all emojis.

Then, in your Compile Format (assuming you are using a custom Compile Format), add the “Emoji” style to the “Styles” pane and set the font size as you wish - something smaller than the size of the font you are using for the text.

I just tested this out and it worked well:

All the best,
Keith

Another approach, if the main issue you have with the look is the uneven leading that results from having a taller element on the line, is the same thing you would take for lines with inline images that are slightly taller than the text or super/subscripts: use a fixed line-height instead of one based on a multiplication of the line content.

It’s probably not a setting you would want to use everywhere, but perhaps if there is a style for your instant messages, you could use it within those:

  1. Open Format ▸ Paragraph ▸ Line and Paragraph Spacing…
  2. Set the Line-Height to “Exactly”, and then input the height manually in points.

With that setting, lines will always be that height, even if there are elements larger than the font height within it. This is why it’s generally not a good idea to use everywhere, since usually you would want a line with 24pt font to be at least that tall, not 16pt or whatever.

Thank you KB and AmberV! Both solutions did the trick. For my workflow the Character Styles approach seemed to make the most sense, so I think I’m gonna stick with that one. Thanks again :slight_smile: