Convert Format to Default Format

I’m finding that converting a draft or individual files to default format doesn’t always persist when I save the file, close it, and reopen the file.

More impressive, I found at one point that if I continued to try to convert to default format, Scrivener would crash. The crashing stopped when I changed the format to the default using the ruler, saved, closed, reopened, and tried converting again.

Confirmed the first part.

  1. I selected Step 8 in Binder.
  2. Converted selected to default via Edit menu
  3. Clicked Step 9, went back to Step 8 to confirm font change.
  4. Closed tutorial; re-opened it; and Step 8 came up with the original font.

So I tried doing a forced save after step 2. Same result.

Next, I tried typing after step 2. That worked. Adding some text cemented the deal. Perhaps it is not properly registering a change in the converted document, and thus it isn’t getting auto-saved? I did notice that the red button never got “dirty,” until I typed, that is.

Thanks.

Yep, this was a problem with saving. It wasn’t a problem with auto-saving, but rather the text documents that were being converted weren’t getting marked as having changes. Actually, I had set it up so that they would get marked as needing saving, but I left one word of code out which meant that it did nothing… This is fixed for beta 2.

However, I cannot duplicate the crash scenario.

kukkurovaca - could you please give more details on the crash, as the current details don’t really help me track it down. Could you please:

  1. List exactly what you did right up to the crash.
  2. Send me the crash log or post it here (read the sticky post at the top of the beta forum for details on how to do that if you don’t know).

Thanks!
Keith

Unfortunately, I wasn’t paying careful attention to what was happening right before the crash. The only thing I did that I haven’t mentioned was that I experimented with making new copies of the files, renaming them, etc. to see if the formatting in them was treated the same. However, I’m pretty sure that was well before the crash. Furthermore, I cannot reproduce the crash, which is something it’s hard to make sound regretful in my head.

I’ll send you the log, though, for whatever that may or may not be worth.

The crash log is interesting… It is the same as the one that Alexwein sent me when she had a crash in a different circumstance. Obviously related. Weird, is all I can say so far. Oh, and thanks.

Hi Keith. I haven’t had another crash of this sort since. It happened the very first time with the very first file I converted to the new Scr. and not again since. I’ve tried to duplicate it by hitting the max button while Scr. was still doing the last bit of processing in making the conversion (right after the window appears) but it’s worked fine ever since. Looks like something that could be difficult to track down, since it’s happening so intermittently and in different circumstances!

Alexandria

Actually, I’m guessing that both of you imported a web archive at some point. Either you imported lots of documents which included an HTM or HTML or two, or you imported a webarchive from the internet directly.

Am I right?

Both crash logs show that the crash happened at a very specific point, after some other very specific events, all of which only happens when Scrivener creates a webarchive. (Can you believe that Apple don’t provide any easy way of converting a web page into a webarchive? There is no method for instance, for taking a URL and turning it into a webarchive. Madness! I had to write all the code myself, which is where the problem lies. :slight_smile: )

Ah, interesting. I know that, in the domain of the command line, textutil can do conversions of file to file, but I have no idea how these things manifest in the realm of programming…however, that does seem annoying of Apple.

You are exactly right about there being an archive! But the web archive was already there in the db file being converted, not added after.

But it was there! So I think you’ve hit it!

Alexandria