Convert to Smart Quotes via keyboard shortcut inverts quotes

MacOS allows you to create your own shortcuts for menu items. When I create such a shortcut for ‘Convert Quotes to Smart Quotes’, and use the shortcut, the quotes are inverted — where there should be an open quote there is a close quote, and where there should be a close quote there is an open quote. However, if I go to the menu itself and select Convert Quotes to Smart Quotes, everything works fine. Attached is a screenshot of the same paragraph twice. The first was converted via the shortcut and the second converted using the menu.

Uploading: Screenshot 2023-03-07 at 9.25.25 AM.jpg . . .

OK. For whatever reason either I don’t understand how to upload a screenshot or it’s not working…

This works fine for me in macOS 13. You might need to specify more details in order to reproduce it:

  • What version of macOS are you using (since this command is native to the OS).
  • What form of smart quote do you use (set at the system level).
  • Have you tried using another shortcut, just to rule out any potential interference from another utility that is perhaps using this same shortcut globally?

Also, make sure you are on the latest version of Scrivener (3.2.3).

I’m using Ventura 13.2.1. At the system level, the traditional smart quotes I think: “Thus”. I did try multiple shortcuts, and they all weirdly invert the quotes while the Scrivener menu produces the quotes correctly. I wonder if anyone with Ventura can verify this.

We are both testing from the same OS version then. That is certainly odd. While I can’t imagine it would make a difference between the menu and shortcut, some other potentially variable things I can think of are:

  • Font family—particularly one that might not have these characters to begin with and font substitution is occurring.
  • Data differences—how the quotes are being used. I just tried a very simple test with one double-quoted phrase in a paragraph, and one single-quoted word outside of it, later in the paragraph.

I tried a number of fonts and the simplest case I could think of:


That was the result. So I’m the only one experiencing this? Scrivener is 3.2.3 by the way. It’s not a huge deal. I can just reach up to the menu when I want to convert. I am curious why it would only be me. That was using Georgia. When I try it with the menu, this is the result:


I’d be curious to see if anyone else has experience with it, too.

What is most odd is that I’m fairly certain there is no difference between using a shortcut and using the menu. The two should be the same code being triggered, it’s just two different ways of executing the same thing. That’s why one of my first hunches is that you had a Service or something taking the same shortcut and basically running the conversion twice.


Meanwhile, the new keyboard shortcut system preferences design is so bad. I hadn’t even looked at it yet, but wow.

  • Select software you want to add a shortcut to, click +: doesn’t designate the software you selected and always defaults to “All applications”. I’m not sure why we can select stuff in this list.
  • Doesn’t remember the last one you used, so if you want to add say twenty shortcuts to a particular program—have fun with that.
  • If you don’t notice that and just make your shortcut and click OK, the failure state is to have no feedback, because “All applications” is collapsed, and the designers failed to add code that expands sections you’ve added things to, so that you get feedback.
  • It’s impossible to copy or move shortcuts from one category to another.
  • It’s impossible to edit the menu command after you’ve created it, and it’s impossible to copy the command text, meaning a typo must be completely re-typed in from scratch in a new entry and the old one deleted.
  • Amusingly, while you can’t edit the menu command text, you can edit the software’s name. Why they thought you would routinely want to change the name of the software associated with the shortcuts, but not ever fix any menu command titles is beyond me.
  • The text field is right-aligned… because wow, so modern and fresh to not type from the left!
  • If you stop to add a shortcut before you’re done typing in the menu name… oops. Shouldn’t have done that! You can kind of continue typing, but only by having half of your keystrokes interpreted as “this is the shortcut” events. And by half, I’m referring to stuff you might really need, like moving the cursor around.
  • Never mind the entire Shortcuts preference pane being in a tiny modal dialogue that you can’t resize, for some inexplicable reason, complete with a save button—which is pointless since it seems settings take effect immediately anyway.

The old shortcuts interface was no stellar example of design either, but at least it somewhat resembled a user interface.