Converting smart quotes

Using Format > Convert > Quotes to Straight Quotes only straightens the opening quotation mark of each set and leaves the closing ones and regular apostrophes in ‘smart’ form.

I have build 6218, running on an Intel MacBook. Smart quotes are switched off in Auto-correct preferences.

Quotes conversion uses your System Preference settings, so make sure they are set up correctly (System Preferences > Language & Text > Text).

Messing about with the various settings doesn’t seem to alter the result. ‘Convert to Straight Quotes’ seems to straighten double quotes completely but leaves the right hand half of a set of single quotes in its curly form (likewise any apostrophes). Hardly a major issue, I realise, but odd :confused:

Can you please provide steps to reproduce? This works fine for me and the code just calls on the System Preferences…
Best,
Keith

  1. With curly smart quotes defined in system prefs, import a .doc or .rtf containing smart quotes
  2. Select text
  3. Format > Convert > Quotes to Straight Quotes

Only the left hand quote of single quotes straightens, the right hand and apostrophes remain ‘curly’. Have had the same result with different fonts, imported, copy/pasted or newly-typed text. Bottom line of the screen grab shows text after conversion to straight:

smartquotes.jpg

Oh bum. You appear to be right, sorry about that! Very strange as this was all tested and working - something odd has obviously slipped in. I’ll fix this for 2.0.1.
Thanks!
Keith

And… Fixed. Spot the not-very-deliberate mistake in the code:

Thank for bringing this to my attention!

Yay! Was beginning to think I was seeing things… :mrgreen:

Talk about seeing double.