Copy and Paste problem Font won't change

When I copy and paste text from word to scrivener. I’ve noticed that I later can’t change the font of the text I pasted. I click to change the font but it will stay the same.

I am assuming you want the pasted material to have the same format as the rest of the Scrivener document, rather than retaining any properties from Word.

If that’s the case, you might try the “Paste and Match Style” option from the Editing menu. The hotkeys for that in Windows are Ctrl + Shift + V

That should allow you to alter the text’s font within Scrivener.

Tried that it still does not let me change it

example I pasted match style

Now when I go and change the font it does not change

I can change it size. When I go and select it tells me I changed the font but it does not display that the font changed.

It sounds like you don’t have the process quite right. The point of using “Paste and Match Style” (Ctrl + Shift + V) is that you don’t need to “fix” the font after the paste.

Here are the steps:

  1. Set up a document properly formatted with the desired font and other text properties.
  2. Copy text from wherever.
  3. Paste and Match Style the text into the properly formatted document.

When done correctly, the pasted text will adopt the formatting that’s already there. No need to change it after the paste.

If it’s still not working for you, create a new, empty document and try with that. This will ensure you’ve got no leftover formatting from prior paste operations cluttering up your document.

Best,
Jim

Oh it changes it to the default font but on some documents I wanted to change a few words to another font.

I’ve tried creating a new document and when I go to change the font in that one it does not let me. It appears to stay the same.

if I try and change the font using that drop down it does not work it only works if I right click and go to

is the only way to change the font for the single word. it appears to be some kind of error or bug

It works for me.

Before Paste:

After Paste and Match Style:

Change font from Header Bar:

So it could be a bug specific to your project, or it could be something you’re not doing correctly. I don’t know, and don’t have any specific suggestions. :man_shrugging: Maybe someone who has also experienced this will come along with better ideas.

Best,
Jim

Fixed it I reinstall it and now its working. It must have been some kind of bug.