Copy and Paste won't transfer more than one space.

Usually in a manuscript I want only one space anywhere, but there can be exceptions where I wand more than one. When I copy from Scrivener two words with five spaces in between and paste into Word, I get only one space. I don’t think it should be that way.

EDIT: I agree, something strange may be happening with pasting rich text, even though simple text works. Pasting rich text into Wordpad works, but not into Word, spaces are deleted. Whereas copying rich text from Wordpad into Word works. Scrivener seems to handle copying rich text in a special way.

Great find, Frank. This happens because Scrivener populates three different clipboards on copy: the HTML, the Rich Text, and the Plain Text. HTML as a document format displays multiple “spacebar” spaces as a single space, though it recognizes forced spaces when entered as the entity   The Rich Text and Plain Text clipboards capture the spaces just as you’ve typed them.

Notepad, and Word’s “Copy Text Only”, use the Plain Text clipboard, so the spaces are retained but the character formatting is lost. I’m guessing that Word uses the HTML clipboard by default instead of the Rich Text clipboard when both are populated. So I’d first see if there’s a configuration setting or a “Paste Special” in Word that instructs the program to paste from the Rich Text clipboard instead.

Or, as Benjamin notes, we can paste into WordPad, then copy again and paste on into Word to filter our copied selection into Rich Text and Plain Text only. We can also insert no-break spaces in Scrivener via the Character Map, and they’ll be recognized in all clipboards.

But Copy as Rich Text Only would be a useful enhancement to Scrivener’s Copy Special menu. Scriv populated the Rich Text clipboard and excluded the HTML for years; it added HTML again relatively late in the beta cycle. So a way to specify which clipboard we favor would be useful in both applications, whether at the clip’s origin or its destination.

Reminder: Scrivener’s HTML clipboard is malformed. A previously reported bug that hasn’t earned a ticket:
Scrivener HTML clipboard not recognized in Chromium-based browsers. Plain text only.

Rgds - Jerome

Or I guess one could just use Ctrl+Shift+Space or Insert > Break > Non-Breaking Space.

(Replies first, thinks afterward.)

Rgds - Jerome