Copy to Word, Correct, and Copy Back

For my last book, I manually corrected the many errors caught by my proofreader. Ugh!

In the future, I want to use Word’s “accept change” functions to accept or reject changes, then copy the text back to Scriv on a scene-by-scene basis.

It looks like this will work, but I need to manually fix the paragraph formatting back in Scriv if I want it to display it the way I’m used to. Annoyingly, I can’t just click on my preferred format from the toolbar dropdown, because that neither affects indent nor adequately describes the formatting.

Alternatively, I could set up the paragraph formatting in Word (OpenOffice, actually) before copying it back.

Do any of you do things this way? Any tricks you’ve learned?

Thanks,

Al

In Scrivener, under Tools->Options->Editor, you can set up your preferred font and paragraph settings. Then you can select any item or items in the binder and go to the menu Documents->Convert->Formatting to Default Text Style.

Note that it will obliterate any special indentation for a portion of a given document (such as block quote indentation in the midst of your standard formatting), so be certain that none of the text in that document deviates from the base-line format before converting the formatting to the default.

Thanks, Dale, that’s nice. Never saw it.

Here’s another problem. In open office, here’s some text with a comment:

Now, even if I choose not to view comments, if I copy the text and paste it into Scrivener, this is what I get:

Anyone seen that? Not sure who’s fault it is, but it is not what I want.

I did a very quick test (using MS Word, not Open Office), and get the same result when pasting with Ctrl+V. If I use Ctrl+Shift+V (Paste and Match Style), the annotation is not pasted in, but there is a blank space where it would be. That’s an improvement, but you still have to remove the blank space; and of course, you lose all other formatting as well.

In Word, select the drop-down to display the final formatting instead of formatting with markup. That should eliminate the space/annotations from being copied back into Scrivener.

Now, I just have to find a similar option in OpenOffice. Anyone?

A workaround is to implement changes, save the document in RTF format, and open that. Comments will be gone. Kludgy, though.

It will be scary to trust that no inadvertent text gets in, but I have a trick for that. I compile to an ODT doc before making changes and after, then compare the two documents. That would alert me to any unintended changes.

You might consider using the Import command, rather than copy and paste. That will use the built-in format converters, rather than just pasting whatever gets put on the clipboard.

Katherine

Thanks, Katherine. I just tried that, and it had the same problems as copy/paste.

At the risk of being hammered down as a heretic, here’s a method an author and I (the editor) use when exchanging LibreOffice “record changes” documents, to and fro into Scrivener.

First, the author drafts in Scrivener, using markdown format. It’s totally ‘nevermind’ whatever appearance formatting is used on the Scrivener screen, as that’s purely for his reading & drafting pleasure. When the draft is finished, he exports the draft as a text file containing the markdown entries, as "[filename].md.txt. He puts this text file into a shared Dropbox folder.

I open the [filename].md.txt file in LibreOffice; it appears as “preformatted text”. I click “Record Changes” and proceed to make edits, comments, & suggestions. I’m careful to respect & preserve the markdown coding. When finished, I “save as” using [filename]-edited.odt … in ODT format, in the shared Dropbox folder.

The author opens it in his copy of LibreOffice, reviews my edits, and when done accepting/rejecting them, he does a “save as” to output the revised file, again as a text file, [filename].md.txt, and he drops that back into his Scrivener binder, either replacing the original draft, or creating a new revised copy.

Note that appearance is never considered in the drafting, editing, or revising process. The “intelligence” of the document is in the markdown coding, not in the various screen appearance choices.

When the editing & revising circus is finished, the author does a Scrivener compile using the multimarkdown option to generate whatever .rtf, .doc, .odt, .pdf, or ePub variety is desired. The author retains the .md.txt versions in the binder as master/archive documents.

That said, should some publisher decide to mark up the submitted manuscript, perhaps in .DOC or .DOCX, and they insist that the author revise it using Word … here’s what we do. Open it in LibreOffice, review the edit/revisions, do whatever judgment requires, and then send it back as .DOC or .DOCX. But a local archive copy is retained by outputting that document to HTML, “Tidy” it to remove the garbage formatting, then filter it through “makefile” (a javascript added to a browser bookmark menu) or “pandoc” (HTML to Markdown) to generate a new [markdown].md.txt file. That’s dropped back into the Scrivener project as a ‘revision’ entry in the binder. All through the process, the Scrivener project remains our “one true version” of our work.

Obviously this markdown exchange method may not work for an academic or formal paper loaded with footnotes, citations & complex formatting, but for most documents it’s just fine.

We do this to avoid being trapped with a proprietary format or a master document that cannot be re-purposed for other outputs. We jealously update & guard & archive our master Scrivener project, with its binder filled with .md.txt scenes and chapters. All else is transitory output.

I’ve found a simpler solution to the comments problem: Click on the down arrow next to a comment, and choose Delete All Comments.

Update: Real-World Report

I recently used this procedure for my 72,000-word book (about 100 scenes).

  1. My proofreader made lots of changes in the docx file.
  2. I went through and accepted/rejected each change.
  3. I read/implemented all the comments, then deleted them.
  4. For each scene, I copied it from the Docx to the appropriate Scriv document, deleted the line added at the end, reverted the formatting, and updated the status. I used an macro to automate much of that:

The process was pretty tedious and scary. I was worried that I might put some scenes in the wrong place, so I had to be very careful.

Two bad things happened:

  1. One scene, when I compiled, had the scene title added to the text. No idea how that happened. I had to delete it, create a new scene, and copy and paste.

  2. I must have skipped one scene somehow, even though I’d set the status to “Final Draft.” That caused some other headaches, but I got it worked out.

Bottom line: This procedure is faster, and probably less error-prone, than making all the changes manually, but it’s pretty tedious and scary.

And…if you write SciFi like I do, and use italics on all the names of your spaceships – the italic Word copy is changed to plain text in Scriv if you cut & paste…sigh…

Plus of course are all the thinking items too…sigh…

But yeah Al, I do exactly the same thing–scene by scene copy & paste, and then have to read the complete scene adding back the italics…sigh…

No, the italics were transferred faithfully. Not sure why it doesn’t work for you. Note that I use OpenOffice.