Copyholder zoom controls don't work when attached to Outliner

Contrary to my confident but incorrect statement here, if the Copyholder is attached to an Outliner Editor, then the Copyholder zoom controls do not work.

The cursor is in the Copyholder, but Menu zoom controls are grayed out:

Similarly, the keyboard shortcuts do not work in this scenario.

The workaround is using the mouse scroll wheel.

Best,
Jim

Thanks, it looks like this is a known issue, I’ve added your post to the ticket’s links.

But Jim wouldn’t you expect that to be, since the active file is the one in the outliner, not the copyholder/other editor window and the menu should be greyed out. if click copyholder in same setting then the view zoom options still work. Note the bottom of the editor will also zoom the lower editor window even if the file is highlighted in the outliner.

I am not sure what you mean, but this can be very simply demonstrated as flawed:

  1. Click on a single text item in the binder.
  2. Alt+drag it to the header bar to load it as a Copyholder.
  3. Click into the Copyholder and press the zoom shortcuts. This is working as you would expect. The text in the copyholder magnifies.
  4. Click over in the main editor and use the zoom shortcuts. Now it zooms. We have established that zooming is specific to where the keyboard focus is.
  5. Press Ctrl+2 to switch to Corkboard in the main editor and click in the Copyholder if necessary.
  6. Use the zoom shortcuts. It fails to magnifying the text in the copyholder.

It is irrelevant what some other area of the project window is showing, whether we should be able to zoom the thing that is focused (if it is capable of zooming).

2 Likes

I agree, the zoom menu options should still work. The bug is that they don’t, as you can see from the screenshot in my OP or by following Amber’s instructions to reproduce the issue. :cry:

Best,
Jim