Corkboard navigation - keyboard?


On the corkboard one card usually has the focus ( denoted by a blue border).
I can move the focus around by using the cursor keys.

However it seems to me I can’t show the underlying document by an easy keyboard press?

I can use the mouse over the card and from the context menu select “Open/Open In Editor”, or I can find the node in the Binder and click on it.

But I can’t seem to find a keyboard shortcut to do the same. I thought perhaps hitting enter might do that, but then you start to type on the actual index card.

Is there some way I’m overlooking?

Try Alt-Shift-DownArrow. Actually that is flawed, but right now it is flawed in your favour. It is acting like Documents/Open/in Editor should (though that menu command seems to be omitted), when in fact that command is supposed to load the text view of the selected item under all circumstances, even if it is a group. Right now, however, it opens groups honouring the current group mode, so it works like the other command should.

Hm, I’m afraid that doesn’t seem to work for me - it just selects all the index cards below the one who has the target.

So you’re saying you want to load the text of the current item regardless of whether or not it has children items and the preferences dictate it should use a view mode? In that case the intended behaviour of this particular feature should be what you want—and as noted this behaviour is currently broken. It should be working the way you request in time. Right now you have to use that shortcut and then turn off the view mode. Since it sounds like you are in corkboard, that would mean Ctrl-2 to turn off the corkboard and edit the container’s text.

Or wait, when you say it selects the cards below the currently selected one, do you mean that literally? That it stays on the same corkboard but moves the selection to the cards following the current selection? Hmm. I don’t see that behaviour. If I select a card on a corkboard on level 2, and that card has three cards on level three, using the shortcut switches to showing the contents of level 3. In outliner terminology, it hoists the view down a level.

You make it sound so complicated and confusing.

I thought I had explained that I’m viewing the corkboard, have highlighted an index card and then wish to open that index card for writing, ie, right click on the card and select the menu “Open/Open in editor” (if I can’t even convey that, perhaps I should give up thoughts of writing larger pieces).

I thought you said it worked because it was broken. But Alt-Shift-DownArrow selects the other index cards below the current one, it doesn open in editor.

Are you saying Alt-Shift-DownArrow in time will open the selected index card in the editor?

Which shortcut?

ye Ctrl-2 turns it off, but it doesn’t show me the selected index card, it shows me the parent.

Yes I meant it literally - like Ctrl-a will select all the index cards. However I had written Alt-Shift-DownArrow selects from the current card to the end, it appears it selects the current one and then the same position on the next level - I only thought it was the end because i had few cards in the corkboard view i was testing.

I should I use the term “highlight” instead of “select” perhaps?

Very odd. Have you changed your keybindings perhaps?

Actually, right clicking on a folder index card and selecting Open/in Editor will load it in a corkboard (as it should) view, showing its subdocuments. It won’t load it in the text editor for writing. So you’re all right, I just misread you because the intended behaviour for that contextual menu item is not about loading the card in the text editor. It’s about loading it in the viewer according to your preferences (corkboard, scrivenings, outliner, or editor as the case may be).

Here is how it should work:

  • Scrivener should in all cases load folders according to your preferred view mode (corkboard as it stands). That means Open/in Editor, clicking on it in the binder, using the history navigation buttons, clicking on a hyperlink that leads to it, etc.
  • Secondary to that, if the option in the Navigation tab is set to treat files with subdocuments like folders, then they will act like the above. Otherwise they will act like text files and always prefer the text editor view.
  • The only exception to that is the View/Go To/Editor Selection. That is a special command meant to override the preferred view mode and just load it for writing in the text editor. Right now it currently doesn’t do that—that’s a bug. Otherwise there would be no point to that separate menu command; might as well just have Documents/Open/in Editor or the right-click version.
  • And also, right now, there isn’t a Documents/Open/in Editor command for some reason—it’s just in the contextual menu; so pretend it is there for the purpose of the above list. :slight_smile:

So right now, there isn’t a way to do what you want: to select a folder card and jump straight to editing its text. You have to load its corkboard and then turn the corkboard off. But, as a workaround to the lack of keyboard navigation, you can at least it with two shortcuts instead of the mouse—and once you do that once it will stay that way until you choose corkboard view again. In other words not using a view mode like Corkboard or Outliner is itself a preferred choice. So you really only need to do that once, until you wish to switch back to viewing index cards, and then you’ll need to switch back to using that as the preferred view mode.

Again, this probably sounds excessively procedural and like a flowchart, but I’m just explaining the underlying logic. In general usage it should just generally be doing whatever you were doing the last time you loaded a container.

Yeah, something is messed up there. I’m not sure why Alt-Shift-DownArrow is just selecting cards for you instead of loading them. If it were functioning properly, then Ctrl-2 would work because the parent in that case would be the card you had selected in step one. I.e. you are viewing Draft as a corkboard, click on Chapter One’s card, Alt-Shift-Down to load the chapter’s scene cards, then Ctrl-2 to edit Chapter One’s text. Since the first part of that isn’t working, you are stuck in the original parent for some reason.

I haven’t changed my keybindings; maybe it’s a version difference? I’m running 1.0.2.

What about Alt-Shift-UpArrow, does that ascend up a level in the hierarchy or does it also select cards spatially on the current corkboard?

… no - it does what i wrote. Perhaps the names are different but it doesn’t stay in corkboard mode, it opens it up in a view with a flashing cursor and formatting tools at the top, and i can type new text into the document.

How do you set ‘preferred view mode’ - clicking on the bar with the three modes on the toolbar? Because that doesn’t work either.

Here I stopped to think you were perhaps being literal with the use of ‘folder’. Because I haven’t been using “folders”.
In the binder you can add new “file” and “folder” (and I’m unclear about what the difference is), but I remembered the manual said …every document you create is a document and an index card and a corkboard and an outline - so i just hit Ctrl-N and make a lot of nodes, which I then rename, start adding in a hierarchy and proceed from there.

However I see that nodes in a tree are not all created equal - seems changing the view of a folder changes all other folders in that tree, whereas checking the setting you just mention seems to make the nodes in document tree retain their view settings but not change all in the tree (so not treated entirely as a folder). I’m feeling all faint!

Is 1.0.2, just installed yesterday. I’m not sure if some of the problem is that I’m new to the family so to speak.

One thing that I think is a bit odd for instance is: I have highlighted an index card on the corkboard. And the “synopsis” is visible in the Show Inspector (and is correct) - i then click Ctrl-2 and the corkboard disappears as expected, and shows the text - but the text is of the parent and not the the card i highlighted - however the Show Inspector is still showing the correct synopsis from the card I selected - ie, i’m seeing the text from one document but the synopsis from another document.

That does the same kind of multi selection except it goes up.

Alt-Shift-LeftArrow jumps into an index card, but it goes into the first one on that level, not the currently selected one.

Ah ha, that explains much then. Yes, if you haven’t touched the navitation preference I referred to before, and are not using literal folders to organise groups of cards (i.e. stacking them together freely), then yes using the open in editor command will jump to text. They will act like text files in terms of navigation (bullet two above). That slight navigational difference is one of the only actual practical differences between a folder and a file. A folder will always drop to view mode, even if it is empty. The navigation preference will make that line even more blurry if you wish. There are two preferences in this regard (a) make folders special above all else (b) make items containing other things special. I myself prefer the latter because I use folders more as an aesthetic marker than anything functional. Merely a larger visual anchor in the outline.

You will come across other differences as well in the Compile settings, but by and large the differences are subtle.

Nothing fancy. Just use a view mode and that is how it will stick until you change it again.

Good catch; that’s a bug. I’ll make sure it gets put into the queue.

Weird, it’s like Alt isn’t getting trapped by your keyboard. What you’re describing sounds like ordinary Shift-Arrow usage, which can be used to expand the selection with the keyboard. International keyboard perhaps? Maybe we have an AltGr problem here.

Well, if that is the case you can customise that to something that works in the Options:Keyboard tab.

Well yes it is an international keyboard, but I’m pressing ‘alt’ not altgr. The alt key also seems to perform the expected results in other applications.

Alt+Left toggles the Toolbar (as expected according to the view menu)

Which option? It seems Alt-Shift-DownArrow is not defined, and there is only ‘Open in external editor’

Also, since I wasn’t sure which keys applied to what focus I was trying a few combinations and notice this:

Ctrl+Down moves an item down in the binder (as expected) - however if I’m on the corkboard and press Ctrl+Down the current Index card retains the blue selection outline, however the Synopsis in the Inspector changes to that of the card immediately below. If I then press Left the index card to left of card below where i started now gets the highlight, it looks as if the highlight jumped diagonally.

Or to put names to that, lets say the top row has Index cards “One”, “Two” and “Three”, and the next row has “Four”, “Five” and “Six”. If “Two” is highlighted and I press Ctrl+Down, the synopsis in the Inspector changes to that of card “Five”, but the highlight is still around card “Two”. If I then press the LeftArrow, card “Four” is now selected, and the highlight jumps from “Two” to “Four”

This thread is very confusing to me.

From another L&L forum I found this (very helpful) hint – double-clicking on the icon of an index card will open it in the text editor. No, it’s not a keyboard shortcut, but it’s (to me) easier than right-clicking and hitting Open>Open in Editor. :wink:

I however, cannot find any way to go from Level 2 on the corkboard directly to the Level 3 cards underneath the parent. I have to click on level 3 in the binder, and then Ctrl-2 to show Corkboard. When I have a card highlighted, hitting Alt-Any arrow key toggles the Header, or Footer, or shifts the screen up or down.

As I said above, I found this thread confusing – and the commands suggested didn’t work for me anyhow :slight_smile: so – IS there a way to to go to the cards on the next level down?

It’s Alt-Shift-DownArrow to descend into level 3. Alt-DownArrow just removes the footer, as you noticed. Alt-Shift-UpArrow ascends back to level 2.

But again, this is flawed behaviour. The command that Alt-Shift-DownArrow is triggering should not be loading a corkboard at all, but rather the text of the card. This thread is confusing because:

  • There is no menu item for Documents/Open/in Current Editor and there should be
  • There is no keyboard shortcut set for for that item and “in Other Editor” as there should be
  • View/Go To/Editor Selection should always in every single scenario load the item as a text file in the editor, even if it is a folder
  • The Alt-Shift-Up/DownArrow shortcuts do not work at all until you view the View/Go To/ sub-menu once per session. Mimetic: This is why you were seeing odd selection behaviour, you need to look at that menu at least once before it will work.

So, a bunch of bugs and behaviour flaws are making this way more confusing than it needs to be. There should be:

  • A keyboard shortcut to load a card in the current editor. If that card is a group, to show it as a corkboard
  • A keyboard shortcut to load a card in the other split, same rules about groups apply
  • A keyboard shortcut to load a card for text editing

Right now none of that works right, and the only one that does work does the wrong thing right now. So use it for that right now, but it won’t always work that way. :slight_smile:


Thank you Amber. That helps – a lot! :smiley:

Just to let everyone know the bugs are filed and I think the confusion going on with Alt+Shift+Up/Down (aside from the fact that it’s exhibiting the wrong behavior) is that this doesn’t work properly in the editor until the menu has been opened. I get exactly the behavior Mimetic described until opening View > Go To, after which it behaves with the expected incorrect behavior in the editor. (That is, Alt+Shift+Up behaves properly, but not Down as that should be always loading the text and instead continues to use the set group mode.)

Btw MimeticMouton, I didn’t try to steal your name, I hadn’t see it when i picked mine :slight_smile:

No worries! I think it’s humorous and ironic. :wink: