Corrupt/Incompat Project Files [User Workaround/"Fix"]

If you are getting either the “project is incompatible” message or the “Scrivener has encountered a problem and needs to close” message, this is how I work around it.

My fix for corrupted projects:

1.) Open your corrupted “Project” file by right clicking the project file Scrivener icon (the yin yang “S” file) within your project folder and selecting to open with wordpad or notepad or another simple text editor. (*Alternatively, open the project file from within the text editor by selecting the “open any file” option when browsing your project.scriv folder.)

2.) In word pad, “cut” or “copy” everything out between and .

3.) Open Scrivener from a non-corrupted tutorial or other project file. If you have no noncorrupted tutorials or files to open it from, you will have to redownload a Scrivener beta and open it from the tutorial. After opening Scrivener successfully, create a “dummy project” – just an empty project for the purposes of creating an uncorrupted base project file.

4.) Open the dummy project file in wordpad or notepad. Delete everything between and .

5.) Paste in the stuff you cut/copied between and that was in your old, corrupted project file. Save and close.

6.) Move the dummy project file to your corrupted project folder. Replace your old project file, or back this project file up in a separate folder before replacing.

7.) Your corrupted file is now replaced and your binder should open as it used to.

Couple quick comments…Doing this will lose/alter your metadata if you’ve changed anything from the defaults–so if for example you’ve added new labels or changed the names of any existing statuses, when you do this you won’t be copying that and it will either end up blank, in the former case, or with the wrong status, in the second (it will use whatever the default status was before you changed it). The blank labels will only stay blank until you create new labels, but if you create them in a different order than you did the first time around, they’ll seem to be mis-applied. (Basically, Scrivener is storing all this information with numbered IDs, so if you add a new label it will be given the ID of 2. There isn’t a default 2, so when the revised project goes to look for it, it won’t exist and will therefore come up as blank in your project. But as soon as you create a new label, that label will be given the id of 2, at which point any documents that formerly had the label with ID 2 will now show that new label, even if it’s not the same as the one you made the first time.) So you won’t have exactly the same project you started with, due to that.

To avoid that, you could copy everything within “Scrivener Project”…given that I’m not sure why this is working, I’m not sure if any of the other information in there would be throwing you off, though I doubt it. But perhaps you tried that and it didn’t work? I don’t have an incompatible project to experiment on.

Unrelated, just wanted to point out that you ought to be able to open Scrivener without having to have a project already. Just run Scrivener.exe.

You! You! You StarTigress are amazingly wonderful. I have been jumping for joy thinking I lost mybig project, and I didn’t!!! Woo-hoo!! Woo-hoo!

Suggestions for folks that do this and aren’t “right-click” literate:
If you don’t see WordPad when you right click on the “Project” file, then browse for WordPad.

Make sure when you save the final project as text only, and just for safty sake make sure the Icon is a scrivener icon after it saves. If it doesn’t ,right-click, and go to “Open With” and make sure that Scrivener is the default to open the file. (Your project file may open in WordPad if you miss this step.) ONce you see that the icon is back to the beloved Scrivener icon, then fire it up. It works like a charm. YAY for resourceful beta testes like StarTigress!!!

You can also just open WordPad then open the .scrivx file through the “open…” dialogue there, as StarTigress also mentioned. Just make sure it’s showing “All documents” and not only text files (as it will be default).

For what it’s worth, if the above doesn’t fix the project, I posted a solution here that worked for a project I was messing with, which seems to agree with a fix someone else had on another thread, so that might be another thing to try.

Yay! I think I figured out why StarTigress’s fix works (um, that may sound rude, I don’t mean it that way at all–I mean to say I couldn’t understand why doing that would fix anything, when I was looking at the data, but I’ve finally pieced together all the different “fixes” that have been working for people and I think figured out what’s going on) so I’ve posted my updated fix in a new thread here. That should take care of the problems with this one I mentioned above, where meta-data doesn’t get preserved, and also I think it may be a little easier for people to follow since the only file you have to edit is the .txt.

I may have discovered one trigger to the corrupt project/scrivener not opening problem. It seems, whenever I create an outline in MS Word, and convert it into a .RTF the problems start. I have done both methods of importing through the binder, and copy/pasting the outline. In both cases I have had trouble, after closing the project I can no longer import the same .RTF outline into another project.

This may only be a problem on my side, but thought it worth someone checking out :slight_smile:

** Just confirmed, this is definitely the problem for me. I opened an outline in word, copied it, and pasted it into the Research section of scrivener. Now whenever I open the project and click anywhere within research, it crashes. I may have been stuck in the research section when this first happened to me. That’s why I couldn’t open the project afterward at all.

I tried this and my project opened. I was overjoyed. However, all my text is missing. Less joy. Are there any other possible solutions?

godorito, probably you know by now that your texts are all kept present, in the projectname/Files/Docs folder.

They’re RTF, so you can open them in WordPad and copy/paste into your new replacement project, if the new project file fix fails to work in your original.

Regards,
Clive

sheepishly Oh. Well looky there. thanks. I looked at that directory repeatedly. Never opened anything in it… facepalm

Thank you for your help.
Mike