Couple of formatting and usability questions

Hello,

I’ve used Scrivener for quite some time but have never really delved deep into understanding the powerful formatting settings. With that said, I’m currently working on a novel and wanted some help on figuring a few things out. I’ve googled a fair amount, clicked around the forum, and watched a number of Scrivener’s videos on Vimeo so I hope my questions aren’t too amateur.

  1. How do I edit the formatting of a block quote after it is compiled?
    So, in my first chapter I use a block quote to emphasize the character reading a letter. While I feel it looks fine in the editor, once compelled it becomes huge and unpleasing to the eye. I’ll link an album with some screenshots of the editor’s formatting, it highlighted (so you can see the paragraph and indent marks), as well as the finalized appearance once it has been compiled.

Screenshots: https://imgur.com/a/7t2eEN6

  1. There is a weird issue where a single paragraph refuses to indent, unless I remove spacing. How do I fix this?
    Once again in my first chapter, I have a list. While formatting is perfectly fine everywhere else, I am having problems with that paragraph immediately following it. Instead of indenting, it just won’t. The only way I’ve been able to fix this is if the paragraph itself isn’t spaced from the list. I’ll attach screenshots once again. First will be an image of the paragraph normally (as in how I’d like it to appear), then highlighted to show format markings, and then compiled. Secondly I will adjust the paragraph so that it formats correctly upon compilation and will attach screenshots of all of that as well.

Screenshots:https://imgur.com/a/PjhKa1d

Thank you all for taking the time to look at this! I’m sorry if I’m overlooking something, and I apologize if these are super specific.

Hi,

On (1), you’ll want to first remove “Preserve Formatting” from the block quote. The blue highlight around it indicates that you have set it to “Preserve Formatting”, which tells Scrivener always to use editor formatting for this paragraph. Once you’ve done that, try compiling and see if it looks better - although this will depend on the Compile format you are using.

If it still doesn’t look how you want - and this is really the answer to the question of how you change the formatting for Compile - you’ll need to override the style in Compile. Now, this assumes that you are using styles (Scrivener 3 only), which I recommend for a block quote. So, if you are not using a style for the block quote, do so - set the paragraph to use the “Block Quote” style, or create such a style (or redefine the current one to look how you want) via the Format > Styles menu.

As long as you are using a style for the block quote, you then need to duplicate and edit the Compile format in Compile (Ctrl-click on the format you are using in the list of formats on the left of Compile and choose “Duplicate & Edit” - or just click “Edit” if that is available). Then select the “Styles” pane. If “Block Quote” is not listed, then click the “+” button on the top right and add “Block Quote”. You can then edit how the style looks in the pane at the bottom. This tells Scrivener to override any text using the “Block Quote” style to look like this. Then you just save our updated format and Compile.

For (2), you will also need to edit (or duplicate and edit) the Compile format. You’ll want to change the first line indent settings under “Settings” in “Section Layouts”. You’ll first need to identify which Section Layout is being used by the document - something that will be much easier in 3.1, which I’m currently getting ready for release. For now, if you’re not sure, scroll through the Section Layouts and look at the “Paragraph first line indents” settings for them in the “Settings” pane and change them accordingly.

Hope that helps.

All the best,
Keith