crash at startup on El Capitan 10.11 Beta (15A263e)

Scrivener crashes the moment I try to start it. Deleting the preferences and Application support and re-installing it let me use it a little while, then it crashes again and will crash on every startup …
Would be great if you could fix it :slight_smile:


Here is the crash report:
Process: Scrivener [1803]
Path: /Applications/
Identifier: com.literatureandlatte.scrivener2
Version: 2.6 (2.60.5)
Code Type: X86 (Native)
Parent Process: ??? [1]
Responsible: Scrivener [1803]
User ID: 504

Date/Time: 2015-08-30 14:33:30.614 +0200
OS Version: Mac OS X 10.11 (15A263e)
Report Version: 11
Anonymous UUID: 351D43F9-1E0A-D7DA-1303-25A49A139A52

Time Awake Since Boot: 3300 seconds

Crashed Thread: 0 Dispatch queue:

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

VM Regions Near 0:
__TEXT 0000000000001000-0000000000357000 [ 3416K] r-x/rwx SM=COW /Applications/

Application Specific Information:
objc_msgSend() selector name: retain

Thread 0 Crashed:: Dispatch queue:
0 libobjc.A.dylib 0x9c1e6cb3 objc_msgSend + 35
1 0x92823f14 __CFTypeCollectionRetain + 212
2 0x92823c6d __CFBasicHashAddValue + 1645
3 0x9282abcc CFBasicHashAddValue + 3132
4 0x92865a3d CFDictionaryAddValue + 221
5 0x92a0c10f mergeFunc + 31
6 0x9285ec81 __CFDictionaryApplyFunction_block_invoke + 33
7 0x9285ec32 CFBasicHashApply + 130
8 0x9285eb69 CFDictionaryApplyFunction + 169
9 0x92a0c0d6 -[CFPrefsPlistSource mergeIntoDictionary:] + 278
10 0x92863694 -[CFPrefsSearchListSource alreadylocked_copyDictionary] + 852
11 0x9285d5f6 -[CFPrefsSearchListSource alreadylocked_copyValueForKey:] + 54
12 0x92a0409d ___CFPreferencesCopyAppValueWithContainer_block_invoke + 61
13 0x929cce1b +[CFPrefsSearchListSource withSearchListForIdentifier:container:perform:] + 715
14 0x92a04026 _CFPreferencesCopyAppValueWithContainer + 182
15 0x92a04153 _CFPreferencesGetAppBooleanValueWithContainer + 51
16 0x92868d17 CFPreferencesGetAppBooleanValue + 39
17 0x90931dc8 _AXInterfaceGetReduceTransparencyEnabled + 47
18 0x9cf7b7dc InitBooleanPrefWithToolboxNotification(unsigned char*, unsigned long, unsigned char ()()) + 80
19 0x9ceec483 _HIThemeReduceTransparency + 36
20 0x9ceec410 IsMenuBarTransparencyEnabled + 123
21 0x9ceec37b _HIMenuUseBackdrops + 11
22 0x9ceebf11 HIMenuBarView::DrawWithoutCustomization(short, __HIShape const
, CGContext*) + 27
23 0x9ceebea6 HIMenuBarView::DrawingDelegateHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 334
24 0x9d080fe3 _InvokeEventHandlerUPP(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*, long ()(OpaqueEventHandlerCallRef, OpaqueEventRef*, void*)) + 36
25 0x9ced2a14 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1832
26 0x9ced1c28 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 402
27 0x9ced1a8e SendEventToEventTargetWithOptions + 40
28 0x9ceeba29 HIView::SendDraw(short, OpaqueGrafPtr*, __HIShape const*, CGContext*) + 433
29 0x9cfadf49 HIView::RecursiveDrawComposited(__HIShape const*, __HIShape const*, unsigned long, HIView*, CGContext*, unsigned char, float) + 785
30 0x9cfae25d HIView::RecursiveDrawComposited(__HIShape const*, __HIShape const*, unsigned long, HIView*, CGContext*, unsigned char, float) + 1573
31 0x9cfad594 HIView::DrawComposited(short, OpaqueGrafPtr*, __HIShape const*, unsigned long, HIView*, CGContext*) + 1136
32 0x9cfad0d8 HIView::Draw(short, OpaqueGrafPtr*, unsigned long) + 84
33 0x9cfad07c HIView::Render(unsigned long, CGContext*) + 46
34 0x9ceea456 WindowData::PrepareForVisibility() + 190
35 0x9cee92bd _ShowHideWindows + 295
36 0x9cee9191 ShowHide + 44
37 0x9d0cca19 MBWindows::GetWindowOnDisplay(unsigned int, unsigned char) + 291
38 0x9d0cbb9b MenuBarInstance::ForEachWindowDo(unsigned char, bool (OpaqueWindowPtr*, unsigned int) block_pointer) + 185
39 0x9ceda812 MenuBarInstance::UpdateWindowBoundsAndResolution() + 158
40 0x9ceda51e MenuBarInstance::Show(MenuBarAnimationStyle, unsigned char, unsigned char, unsigned char) + 266
41 0x9ceda158 MenuBarInstance::UpdateAggregateUIMode(MenuBarAnimationStyle, unsigned char, unsigned char, unsigned char) + 732
42 0x9ced9e74 ___ZL25UpdateAllAggregateUIModes21MenuBarAnimationStyleh_block_invoke + 57
43 0x9ced9d98 MenuBarInstance::ForEachMenuBarDo(void (MenuBarInstance*) block_pointer) + 42
44 0x9d0cb7b7 UpdateAllAggregateUIModes(MenuBarAnimationStyle, unsigned char) + 140
45 0x9ced9b81 SetSystemUIMode + 185
46 0x9ced9abe ShowMenuBar + 126
47 0x9a1bec10 -[NSApplication finishLaunching] + 1410
48 0x9a1be2b6 -[NSApplication run] + 315
49 0x9a139250 NSApplicationMain + 1630
50 com.literatureandlatte.scrivener2 0x000023f5 0x1000 + 5109

Thread 1:
0 libsystem_kernel.dylib 0x9846ae16 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x91c7e58d _pthread_wqthread + 1289
2 libsystem_pthread.dylib 0x91c7bfde start_wqthread + 34

Thread 2:: Dispatch queue:
0 libsystem_kernel.dylib 0x9846b8b2 kevent_qos + 10
1 libdispatch.dylib 0x95a639c5 _dispatch_mgr_invoke + 234
2 libdispatch.dylib 0x95a635ae _dispatch_mgr_thread + 52

Thread 3:
0 libsystem_kernel.dylib 0x9846ae16 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x91c7e58d _pthread_wqthread + 1289
2 libsystem_pthread.dylib 0x91c7bfde start_wqthread + 34

Thread 4:
0 libsystem_kernel.dylib 0x9846ae16 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x91c7e58d _pthread_wqthread + 1289
2 libsystem_pthread.dylib 0x91c7bfde start_wqthread + 34

Thread 5:
0 libsystem_kernel.dylib 0x9846ae16 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x91c7e58d _pthread_wqthread + 1289
2 libsystem_pthread.dylib 0x91c7bfde start_wqthread + 34

Thread 6:
0 libsystem_kernel.dylib 0x9846ae16 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x91c7e58d _pthread_wqthread + 1289
2 libsystem_pthread.dylib 0x91c7bfde start_wqthread + 34

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0x019195d0 ebx: 0xa2772110 ecx: 0x9c202b0b edx: 0x019b52c0
edi: 0x00000000 esi: 0x019195d0 ebp: 0xbfffe5d8 esp: 0xbfffe5b4
ss: 0x00000023 efl: 0x00010202 eip: 0x9c1e6cb3 cs: 0x0000001b
ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x0000000f
cr2: 0x01b30008

Logical CPU: 0
Error Code: 0x00100170
Trap Number: 132

Binary Images: /cut out/

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 1
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 2831
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=234.5M resident=0K(0%) swapped_out_or_unallocated=234.5M(100%)
Writable regions: Total=58.2M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=58.2M(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Activity Tracing 2048K 2
CG image 4K 2
CG shared images 176K 5
CoreAnimation 32K 3
CoreUI image file 192K 4
Foundation 64K 2
Kernel Alloc Once 4K 2
MALLOC 43.1M 23
MALLOC guard page 48K 11
Process Corpse Info 2048K 2
Stack 10.6M 8
Stack Guard 56.0M 8
__DATA 11.1M 241
__IMAGE 528K 2
__LINKEDIT 51.6M 16
__OBJC 4660K 92
__TEXT 182.8M 249
__UNICODE 552K 2
mapped file 108.6M 106
shared memory 324K 8
=========== ======= =======
TOTAL 474.3M 778

Model: MacBookAir6,2, BootROM MBA61.0099.B19, 2 processors, Intel Core i7, 1,7 GHz, 8 GB, SMC 2.13f15
Graphics: Intel HD Graphics 5000, Intel HD Graphics 5000, Built-In
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, -
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, -
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x117), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.4.0f3 16298, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM0512F, 500,28 GB
USB Device: USB 3.0 Bus
USB Device: Card Reader
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: Intenso Micro Line
Thunderbolt Bus: MacBook Air, Apple Inc., 23.6

I’m in the same exact boat - same crash and everything. The only reason I took the plunge on trying El Capitan was reading that Scrivener worked in the more recent PBs, but that doesn’t seem to be the case in PB5 or PB6. I tried a bunch of the solutions that worked for previous betas, but none of that seems to work now.

If you create a new test account on the Mac and try to run it from there, does it work? If so you it’s practically certain to be a problem with your user folder. Personally I prefer to start a new user folder from scratch when I beta test the OS anyway, and I don’t run anything in the background (like Dropbox etc.) unless it is clearly marked as being ready for testing in the beta OS X. I’d also do a safe boot to flush out temp folder junk and caches that may have been carried over from the prior OS.

It may still just be a general beta crash though. I’m not sure if Apple has sorted out all of the 32-bit bugs they introduced in earlier builds.

Yep, it works fine on a new account, so the problem must be with my user folder. But I wouldn’t know where to start in troubleshooting that. I followed your safe boot suggestion but that doesn’t seem to have sorted it out on my user account.

(fwiw, I’m not completely deprived of Scrivener, since I do have it on my Windows partition as well, but it would be nice to get it working on here again!)

I really don’t recommend updating your only Mac partition to a beta operating system. Nothing is expected to work, most of all third-party software, but even Apple’s stuff (Mail, whatever) can be pretty buggy if it’s being updated that year.

That aside, what I would do in your situation is take up residence in the new user folder and copy your data over from the current one, changing the ownership to the new account. It’s a low risk move because you can always log into the old account and nothing will be touched. You can get a lot of settings back by copying Application Support folders and preference files over when you intend to run a program. I used this routine on my most recent upgrade, brand new folder, but rebuilt quickly to its familiar state from the archived library files of the old folder.

FWIW, I’ve run all the El Cap public-beta versions (as they have been released) on two Macs and using my regular user accounts on each machine (and Dropbox to store files), and so far I haven’t had a crash on either Mac when using Scrivener.


  1. Uninstalling Scrivener; cold booting; grabbing a fresh download of the latest Scrivener build; and reinstalling?

  2. Resetting PRAM and SMC?

@AmberV - I understand what you’re saying - but it’s already done. No point in trying to close the stable door now. Like I said in my post, I was led to believe Scrivener would work fine. Everything else works great, funny enough, but not Scrivener. Really, this is an inconvenience rather than a world-ending issue, because I can boot up my Windows partition in VMware Fusion and have Scrivener running anyways.

@Briar Kit - I did all of those things, and had no luck, unfortunately. Still crashes. I’ve also done things like delete (well, archive) Application Support files and Preferences, then reinstalled, and still had no luck.

Edit: As a side note, I noticed that my crash isn’t exactly the same as the OP’s, so I’ve pastebin’d it here:

Edit 2: I’ve also pastebin’d the console log. I hope this information is helpful!

By someone at Scrivener?

I guess it does work fine in the other user account, and other people aren’t having the same problem, so it doesn’t look as though Scrivener as such has a fault of its own: something has to be in conflict from the settings in your account.

Worth deleting all the cache files in the user account, rebooting, and forcing OS X to run its maintenance scripts from Terminal?

sudo periodic daily weekly monthly

No, there is a list I found of which apps work in El Captain and which do not. Scrivener had long been on the “not working” list, but moved to “working” - which is technically true, but not on my user account. Now I know better than to trust random internet lists! :stuck_out_tongue:

I’ve done all of those things, but had no luck. I’ve also done things like disable user fonts and remove other things that might cause issues. Still no luck. I’m not terribly fussed about having to wait until the next public or beta release of Scrivener, but I am worried that I’ll still be having problems after then - since it works fine for you, for instance, but not for me.

Guess we all take calculated risks with beta software.

I think there’s a thread somewhere in which Keith (or Ioa?) mentions that an updated version of Scrivener will be released around the same time as El Cap’s formal launch. Hopefully that will erase any issues that might still exist at that point.

Good to have VMware and Win Scriv a few clicks away.


One thing I found interesting is that by returning my old Application Support/Scrivener folder and Scrivener’s Preferences files to their original location, I got Scrivener to start up, at which point it gave me the usual 30 day trial notice. So I went into my emails to retrieve my license, put it in and then Scrivener promptly crashed, and is now back to its usual crashing pattern at start-up.

Now the start-up crash I’m seeing is very slightly different - in fact, it’s the same as the OP’s. So I’ve pastebin’d it here. After this I fiddled with the same stuff (deleting those files, clearing user cache, adding them back, etc.) and got the app to start up, but no windows appear. The menus were all present but trying to do anything with them caused a crash. I can’t seem to reproduce this now.

I read about the planned updated version before 10.11’s formal release - is there a chance we’ll see a beta version before release? Like I said, I’m worried that things still won’t work after that point. I think I can live with running Scrivener in my Boot Camp partition through VMware for a month or whatever. Part of my reasoning in trying to find a solution to my issue is so that it can benefit someone else who has the same situation, and because maybe something can be learned from it other than “don’t install beta operating systems on your primary/only machine.”

We’re going to be getting Scrivener 2.x in 10.11 ship-shape over the next week or so, and there may well be a public beta. The trouble is, though, that none of us can reproduce these crashes and they look like OS X preferences crashes, so I doubt there is anything we can do our side to prevent these. They are more likely going to take some troubleshooting and removing of problematic plugins or corrupt files on the user end, although we will of course try to help with that where we can.

All the best,

That sounds good. Is there a demand for closed beta testers? It’s something I have experience in with OS X and iOS software and would be happy to help out with, since I’ve used Scrivener for many years now, in many different capacities. I’d happily volunteer my services if needed.

In any case, I’ll continue to try to figure out a solution to this problem myself and will post if I find anything new.

Ergo, you know the exact date of El Cap’s public release? :smiley:

Developers know no more than consumers. But they said Autumn, so we’ll start preparing.

Salakatika - do you have any Accessibility options turned on at all?

Nope, none.

That’s rather hard on the devs; making them rely on their psychic powers. Still, in Kernow, anything magical is possible.

Anything strange or different going on with your menus, then? The crash log seems to indicate something in the menu set-up (all Apple internal stuff, nothing in Scrivener’s own code) is triggering some sort of preferences or dictionary crash. Any special settings with your menus, either via OS X system preferences or third part tools?

If you go to System Preferences > Users & Groups > Login Items for your account, what is listed there?

Also have a look in /System/Library/StartupItems and /Library/StartupItems to see if anything is in there.

You might also want to try disabling all Extensions via System Preferences temporarily, to see if any of those are having an effect.

Clearly, something your main account is interfering, but it’s a case of trying to narrow down what it is.

At some point they release a “Golden Master”, at which point you know it’s only going to be a couple of weeks or so until release, so that is usually the point at which you know you better get ready to submit to the App Store. Also, they usually forbid any apps built on the beta OS from being submitted to the App Store, and then at some point send out an email to developers saying that they can now submit using the latest OS - which, again, is a sign that release is imminent. We find out the actual day along with everyone else, though.

Nothing strange or different that I’m aware of - no special settings or anything like that. It’s all basically vanilla. I don’t have anything installed that alters these.

Just a small handful of apps like Flux, Dropbox, Radium (internet radio), Alfred, etc. I removed all of them and logged back in - no effect.

The former folder is empty, and the latter only contained a daemon for usage of an Xbox 360 controller with OS X. Removed it - still the same result.

Also did this. Still no change. :confused:

I rebooted and tried different things (e.g., running it with/without Scrivener’s pre-10.11 Application Support and Preferences files) - at one point, having done all of the above, I was able to get it to start up and run fine, but only once. When I closed it and opened it again, it went back to its normal crashing behaviour. At various points, instead of crashing it has opened with no windows present - if I open a test project, this is what the result is. I should stress that the binder is not supposed to be empty.

Edit: This is my most recent crash.

Your crash log mentions Growl.* That hasn’t been updated for nearly two years. Could that be the source of the problem?

  • Apologies if I have misunderstood the ref in the log!