Crash on iPad, iOS 11 Public Beta, today’s Sept 6 update

Scrivener has worked perfectly on both my iPad and iPhone using iOS 11 public beta, but after today’s update the iPad version crashes immediately upon launch every time. The iPhone continues to work fine. Is anyone else having this problem? iOS reset on iPad doesn’t help.

I’ve just installed beta 10 (today’s beta) and it works fine for me on my iPad. My guess is that the install has corrupted your Dropbox settings somehow - Scrivener can crash on start up if Dropbox gets messed up (something I’ve been working on but some of the crashes seem to happen in the Dropbox frameworks). Please try the following:

  1. In Scrivener’s entry in Settings app, under “Syncing and Sharing”, turn off “Auto-Detect Changes”.

  2. Try opening Scrivener - does it work?

  3. If so, try syncing - does it crash still or go through with the sync?

  4. If it goes through with the sync, you can turn “Auto-Detect Changes” back on.

I wouldn’t say Scrivener has been working perfectly so far, though! Unfortunately Apple has completely broken the rich text system in the latest iOS 11 betas. For instance, once you’re back up and running, try this:

  1. Starts new document in Scrivener.

  2. Type a line of text.

  3. Hit return and type another line of text.

  4. Change the first line of text to red and italic.

  5. Now place the cursor at the end of the second line (the one that isn’t red and italic) and start typing.

The newly-typed text will be red and italic. This is because iOS 11’s UITextView has a serious bug whereby all new typing tries to use the formatting of the first letter in the text. It’s a crazily nasty bug. I’ve reported it to Apple as bug ID#34239348, and would be very grateful if you could report it to them to as a beta-tester, in the hope that the more reports they receive, the more likely they are to fix it. I spent a couple of days working on a workaround in case they don’t, but the workarounds are brutish and nasty.

Thanks and all the best,

Thanks for the speedy reply, Keith. I tried turning off auto -detect – no luck. But here’s another clue : before I updated iOS, it appears I had Scrivener and Safari sharing a split screen. After the update Safari crashed immediately, too, and in exactly the same way: the app doesn’t open at all, the screen flashes white with the Scrivener “S” for a millesecond and vanishes. I don’t think there’s time for it to try to sync anything to the internet.

Another clue: when I double-clicked the home button, I could see Scrivener and Safari as a split screen, so I swiped them to close those apps. Safari now worked fine but Scrivener did not.

Another clue: when I try to open Scrivener and it crashes, I can double-click the home button and see Scrivener clearly. If I swipe it to close it, it still doesn’t work.


Same here, with both the latest public beta and its predecessor. Switching Auto-Detect on and off did not change anything either.

After Scrivener had crashed I can see its minimized window (or whatever it is called in iOS) when I swipe up and in it a text from a project is clearly recognizable. But I don’t think I had left a project open the last time I used Scrivener.

SOLUTION: reinstall Scrivener and it works fine. (I made sure all my projects were in dropbox and synced, of course.)

Keith, I just repeatedly reported the text color bug - once for each app where this is true, including Scrivener.

Thanks for reporting the text bug. Unfortunately, it still exists in the iOS 11 GM beta - I’m shocked they are letting something that critical through; it’s probably the worst bug I’ve ever seen make it to a public release. Out of interest, what other apps did you see the problem in? I don’t know of many others that use the iOS rich text system quite like we do, so I’m curious where else it is manifesting itself.

There were two others. One I don’t remember (I’ll poke around again), the other was Documents by SavySoda — but I just checked and this app isn’t on the App Store any longer…


Great, thanks. I managed to find a few free apps with the same problem: Mach Write, TextEditor, Just Write, WriteIdeas and noteCafe Style. No doubt there are some paid ones that I didn’t try out with the same issue, too. I hate having to put use my hacky workaround - I really hope Apple fixes this in an early update, as it’s a crazily bad bug to make an official release, probably the worst I’ve seen in terms of things that affect Scrivener.