Crash on launch after major changes to Dropbox folder contents

Looked but didn’t see anything similar to this, so I thought I’d report it.

I deleted a project from the S iOS dropbox folder and merged several Word files into a different project. If effect, I made changes to all the files in the Dropbox folder (either deletions or additions). After my changes, I was left with one (vs. three) S project file about 18MB in size. I did all this on my Mac.

(For what it’s worth, I use a "non standard–i.e, not the Apps–>Scrivener–folder for my projects, which works just fine.)

I then launched S iOS app on my iPad to let it sync my changes. S iOS/iPad ran a few seconds with the sync progress indicators whirling before exiting to the iOS desktop. Subsequent launches had the same crashy result.

Interestingly, S iOS on my iPhone 6s did a quick sync without crashing but the S project in the Dropbox folder didn’t appear. I went into settings and confirmed that S iOS/iPhone was pointing to the correct folder. It was. I reassigned that same folder to the app and the S synced correctly.

I solved the iPad problem by deleting and reinstalling S iOS/iPad, configuring it to point to my user-designated sync folder, and letting it sync. Everything worked as expected after the reinstall.

I haven’t duplicated the issue — unfortunately I don’t have the time to create a bunch of test projects and repeat the file manipulations. The issue isn’t a biggie since a reinstall solves it nicely, even though, depending on the number and size of projects, that can take a bit of time. I have to note that this is the first time I’ve seen the iOS app crash. Was beginning to think it was impossible.

Thanks,

Jim

There is a known crash that can occur if the designated Dropbox folder is deleted, renamed, or moved. It sounds like you may have encountered a variation of this problem. Thank you for calling it to our attention.

Katherine

I am also having this issue. I attempted to share my Dropbox Scrivener folder to another Dropbox account, to access on our family shared iPad Pro. Prior to this, my Scrivener project was there, and I could edit it. I changed the Dropbox sign in to the shared Dropbox account, and Scrivener started crashing on opening it. I changed the Dropbox account to the same account it was before, but Scrivener still would crash. I uninstalled and reinstalled both applications and set Dropbox to the original account (and then again did the same with a reboot of the iPad after). Both times, when I hit “Sync” in Scrivener, the Dropbox syncs, and says it’s up to date, but does not show the project any longer. I expected after reinstall that I would be asked to sign in and import the project again, which it did not ask me. Dropbox app was also reinstalled, and wasn’t even signed in at the time I tried this.

At any rate, it seems that I cannot add my Dropbox project back into Scrivener on my iPad Pro. I can once again open Scrivener on it, but no amount of troubleshooting seems to be allowing me to re-add the Dropbox project file. Any advise on how to completely reset on my device would be greatly appreciated.

Thank you,

Donovan


Edit:

I seem to have solved this problem - re-reading the original poster’s post, I realized that I had been using a non-standard folder in my original account. I was able to move the .scriv file to the Apps/Scrivener/ folder that was now present, and was able to open the file with just a press of the sync icon. I then re-shared the Dropbox folder (at the “Apps” level) to the other Dropbox account, and reopened and did a sync, and all worked from the shared Dropbox iPad. Next step was to reset the Scrivener on my other iPad to match the new folder, and all was good. I’m going to make sure it all synced right to my desktop, and if you don’t hear back from me, all was well.

That’s it exactly. Didn’t move it, but did rename it. As I explained, not a big problem; a reinstall took care of it.

Jim