Crash when importing text files

I still can’t make this work and it’s really testing my nerves. Images and even pdf worked just fine by dragging the files from Finder window. When I try to add text files the programme just freezes. Every time. Application not responding.

I tried all the above, .txt and .rtf files, with and without # as a separator, etc. I got all the proper tick boxes, but after that nothing happened. No text whatsoever, not in one or separate notes.

Now this happened when I tried to copy-paste a list of like 7 items, which worked fine just a while ago.

Like, what the hell?? I just downloaded this and was quite excited about the whole idea, but this doesn’t seem to work at all now.

I’ve split your post to another thread, as the other conversation was about how to cut each line in a text file into a new note, but it appears you are reporting a crash when importing text files, generally. I don’t think these things have anything to do with one another, but sorry if you meant them to be connected.

It would help to know what OS version you are using. I’m testing on 10.14.6 and everything is working fine with importing text files. Also try with very basic tests, make a simple three line UTF-8 .txt file with TextEdit, for example, and try with that.

I’m using Sierra 10.12.6 .
I tried this again, with a few lines of simple text.

(a) saved as Unicode-8 it makes a textedit-file without extension. That dragged to Scapple produces a link to the file.

(b) ticking the “if none is spesified use .txt” when saving in Textedit made a .txt-file as expected, and dragging this to Scapple I get the box asking if I want to split the file to multiple notes. Choosing this and one (return) as a separator can be done, but then it sort of freezes. Nothing seems to happen, but trying to work with the Scapple file or drag anything else in it results in nothing. Closing the Scapple file at the latest shows that it is not responding.

I’m not seeing any crashes

Hmm, unfortunately I have no way to test with 10.12 these days. We did make some adjustments to importing for the next update (which should be coming out soon with the release of macOS 11), so I’d recommend waiting to see if that fixes things for you.

In the meanwhile you should be able to copy and paste and use Split to break up things into notes. Not nearly as convenient, but the only good alternative I can think of is to use drag and drop from Scrivener, if you own it (although if you don’t, the free demo may suffice to get you through until the update).

Ok, great! So is this going to be a big one?
Meaning that if I run out of Scapple trial days before that and get a licence, will I get this as a free update or not?

Split from the menu bar seems to work ok, so at least there’s that. Although it’s sure slower.

And actually, I have been using Scrivener for 2-3 years now. Getting these to work together is the obvious next step! Following the intro video workflow I didn’t realise that at least I can get list as one note just dragging it from Scrivener… :laughing:

Nothing major; it is mainly going to be some bug fixes and a few adjustments to keep it working on the latest OS. So yes, you would get this update for free no matter.

Well in that case! If you’ve got a long list of things to break up, try this:

  1. Create a throwaway Scrivener project from “Blank”.
  2. Use the File ▸ Import ▸ Import and Split… menu command, and set that up as you want.
  3. Select the list of imported items from the binder and drag them over to Scapple.

It’s still less convenient than splitting right in the program, but if you’ve got several dozen of them, surely better than hitting Split over and over. :slight_smile:

Nice, thank you! I guess I’ll manage with these for now and look forward to for the update :stuck_out_tongue: