crash with embedded media file

I was getting a crash situation that has now gotten worse. It first happened when I had created a file, added a media (audio) reference via the supporting material pane, and then embedded another audio file in the rtf itself. All was fine until I tried playing the referenced audio file in a split view. It stuttered, then the program crashed. I tried deleting the reference and adding it again, the same thing happened. I deleted the entire file, recreated it again with different media files, and it crashed again as soon as I tried playing the referenced file. But only when I embedded another audio file in the rtf itself. The embedded audio plays fine, btw. It is the referenced file that cannot be played.

Now, however, I cannot get out of it. The file, obviously corrupted in some way, is highlighted when I open Scr. and as soon as I try to trash it or do anything at all, instant crash. I tried dumping Scr.'s preferences file, but that doesn’t help.

So I’m stuck! I can’t get away from this file without the program crashing. I can send you the crash report. It will be long, since I’ve tried many things to test it then to try to rectify it.

Alexandria

I just tried embedding a movie file in a test rtf and it crashed the program, just like the referenced file did in the previous example. Which is strange, since in the previous instance, the embedded file worked and the referenced file crashed it.

I’m going to try more things to see if I can pin it down more.

Yeah, just tried again to embed an audio file, a different one, and the program crashed as soon as I tried to play it or switch away from the file. So it appears the problem is the embedded audio or movie file.

Btw, I’m selecting alias from the dialogue window that pops up. I don’t even need to play it for the program to crash. I just created an rtf, embedded an alias of an audio file, and moved away and boom, Scr. crashed.

Sorry for the PSS’s. I’ll do more checking first before I post the next time so I can be clearer. Thanks!

I’ve managed to crash it too, by embedding a media file and having an actual media file (reference) in the other view.

The stuff that is coming up is weird - all innner-working Apple stuff. I hope it’s something I can fix…

Thanks,
Keith

Me too. :slight_smile: Sounds like a strange one!

Wow… This one is dreadful. If you have an embedded movie and try changing documents, the app will crash. It doesn’t seem to have anything to do with references - just embedded media files. What the?

Yeah, that’s what I found eventually. And I have an entire project (not a very extensive one yet) that I can’t get out of the crash cycle. If I open the project, the bad doc is highlighted. If I try to trash it, Scr. crashes, if I try to change documents, Scr. crashes. I may just have to start over. Of course, that’s on me, since we are working with betas and that happens with betas! But it’s the first and only crash I’ve had using Scr. thusfar.

Alexandria

To get your project up and running:

  1. Make sure your project is closed.

2 Trash Scrivener’s preferences (com.literatureandlatte.scrivener).

  1. Open your project again. There will be no selection now that the preferences are trashed.

  2. Open all groups necessary to find your bad document by clicking on the disclosure triangles. Make sure that you do NOT select the actual bad file.

  3. Drag the bad file into the trash. Make sure you click on it and drag in one action so that it doesn’t get displayed in the editor first.

6). Wait for auto-saving to kick in (that is, wait until the dot in the red button in the top-left corner of the app disappears). Given that the document will now be selected, the app will crash whenever you try to do something, so you must wait for the program to save so that the document will be in the trash the next time you open the program.

  1. Close the program and then trash the preferences file again.

  2. Open your project again. Again, there will be no selection. Now you can go to Edit > Empty Trash to destroy the document causing the crashes.

Your project should now be fine to use again. I seriously recommend staying away from embedding QuickTime files until I have tracked this down (note that embedding images and PDF files should be fine - this is a specific QuickTime issue).

Many thanks,
Keith

As an extra precaution, right before step 5 you could lock the editor view.

Actually, I forgot about that - that should prevent the need for trashing the preferences file the second time.

That worked like a charm! (And I used your tip, AmberV). Thanks to you both!

Alexandria

Any problems with putting back the original preference file? Just because I’m lazy and don’t want to redo it all. :slight_smile:

Alexandria

It should be fine. It will try to load the document, find it’s not there and so display “No Selection” (I hope). Let me know if not, though, because I haven’t tested it. :slight_smile:

It turns out this bug was present in Scrivener Gold, too… Painful.

Ugh. Not fun. Leave it to me to find a bug having to do with QT files, as much as I like to play with them.

I returned my original pref file and Scr. is humming along nicely. Thanks for your help with this!

Well, it seems as though this is a rather serious Apple bug. I have filed it with Apple and also mentioned it on the dev lists, and I received a reply from an Apple engineer within minutes saying they would look into it.

Until then, my only real option is to disallow movie attachments within the main text. The problems arise from trying to swap in and out text with an attachment when it can appear in more than one place at the same time, so I’ll still allow QuickTime attachments in the notes for now.

Hopefully this isn’t too big a deal given that we have a dedicated movie view.

Thanks,
Keith

As long as I can use the references pane to attach QT files, I’m fine. It would kill me (okay, not literally) to not have that ability, since if I loaded all the QT files into Scr. itself my file would be insanely huge. And I’d have duplicate QT files eating up my disc space. What I do now is house them all in iTunes as my central warehouse and alias them to other places as I need them.

The need to embed them isn’t that critical, because I can do it in other programs and that kind of scenario is not really what I use Scr. for anyway. I discovered this bug by accident, really. I had a referenced QT file and dragged it into the editor just to see what happened. And something definitely happened! :slight_smile:

Thanks for letting me/us know.

Alexandria

Oh, referencing in the references pane and using the normal QuickTime view are absolutely fine. This bug only affects embedded files, so that is all that will be disallowed. I doubt there is often the need to embed a QuickTime file into text anyway, especially in a program such as Scrivener where it would just be much better to have a separate QuickTime file with any notes stored in the notes pane.

I’ll restore the embedding ability once Apple fix this or I hear back from the engineers that there is a different cause.

Thanks,
Keith

Sounds great!