Crashes when saving snapshot or adding files

I just installed the latest Scrivener on my two Arch linux systems and have been getting a few consistent crashes when trying to save a snapshot or add a file to the reseach folder. In all cases on my 64bit system running it through gdb gives the same output:

[code]GLib-ERROR **: gmem.c:405: overflow allocating 1953723755*4 bytes

Program received signal SIGTRAP, Trace/breakpoint trap.
0xf4e6f019 in g_logv () from /usr/lib32/libglib-2.0.so.0[/code]

Running on 32bit it complains about incompatible version of QT (even though both are running 4.8.1). I can get it to run by downgrading to 4.8.0 which still crashes for the same reasons, but is a little more informative with output
Snapshot crash

[New Thread 0xb2ae4b40 (LWP 7056)] [New Thread 0xb22e3b40 (LWP 7057)] [Thread 0xb22e3b40 (LWP 7057) exited] [Thread 0xb2ae4b40 (LWP 7056) exited] [New Thread 0xb2ae4b40 (LWP 7058)] [Thread 0xb2ae4b40 (LWP 7058) exited] [New Thread 0xb2ae4b40 (LWP 7059)] [Thread 0xb2ae4b40 (LWP 7059) exited] Setting new source /opt/Scrivener/bin/Scrivener: symbol lookup error: /usr/lib/kde4/plugins/phonon_backend/phonon_gstreamer.so: undefined symbol: _ZNK6Phonon11MediaSource3mrlEv [Thread 0xb0973b40 (LWP 7025) exited] [Thread 0xb129cb40 (LWP 7024) exited] [Inferior 1 (process 7018) exited with code 0177]

Adding a file:
lots of errors of MIME info, lose beginning ends with

[code]“Warning: Mimetype ‘video/x-zmbv’ supported from Phonon but no suffix mapping”
“video/x-zmbv”
[New Thread 0xab17db40 (LWP 8922)]

Program received signal SIGSEGV, Segmentation fault.
0xb430bb8e in KDirModel::itemForIndex(QModelIndex const&) const () from /usr/lib/libkio.so.5[/code]

Relevant package versions
64 bit glib2 and 32bit glib2 = 2.30.2. The 32bit system is running testing repository and updated to 2.32.1 today
phonon gstreamer = 4.6.0
libkio.so.5 belongs to kdelibs 4.8.2
Scrivener installed from the tar.gz file in both. Tried converting the .deb into an arch package and had same issues, not surprising since they seem the same other than where I installed the .tar.gz and the inclusion of some icons and docs in the .deb. Incidentally, it might be nice to include those in future tar.gz installations

So it looks like the 32-bit crashing seems to be solvable by the same process of unset QT_PLUGIN_PATH that needs to be done to get things to work with new versions of QT. I still get a crash with on the 64-bit version, probably due to my system supplied 32-bit gstreamer getting confused by my system phonon and the phonon libs that are shipped with Scrivener

I also suspect the only reason I’m getting the crash when doing a snapshot is the sound effect, which would be nice to be able to disable even if it wasn’t causing a crash.

Hi!

Where exactly i need to put this: unset QT_PLUGIN_PATH

Because Scrivener crashes all the time if i want import a picture in the research folder. I use it on
Ubuntu 12, 32-bit

greetz

Running 64-bit Arch with a 32 bit install of scrivener from AUR and can confirm crashes when saving a snapshot on the latest version (1.2.5). “unset QT_PLUGIN_PATH” is included in the bash script which calls scrivener from /opt/scrivener. Even with this set, scrivener crashes on snapshots and various media-related actions.

Has anyone figured out a workaround on this yet?

Thanks for the confirmation idiotmagoo. Still getting it with the new version that was just released. I have started fooling around with a fedora installation that behaves slightly differently however. Running from the command line I get an error about not having gstreamer plugins and says it will disable sound (sorry for not thinking to copy the exact error, will edit post next time I boot into that installation). I’m still figuring things out on that side and likely have some that I still need to install, but at least points to something in those packages that is the culprit.

I experimented with removing my various Arch gstreamer packages, but they all either had no effect or caused Scrivener to not be able to run at all.

dawinschi: sorry for not responding, you posted right around when I was had my thesis defense, and I must have missed the notification. I think the .deb you are probably using had a script in /usr/bin/scrivener similar to the way I wrote the arch package I made, you can add the line to that before it runs the Scrivener binary.

idiotmagoo: I noticed you posted a similar question about how to unset the path on the AUR, but seem to have deleted it. Looks like you figured it out yourself.

Right. I think the lib32 gstreamer packages are causing this issue. The versions in arch aur are pretty inconsistent (and bleeding edge) in comparison to what scrivener is building against in ubuntu.

No problem. I was just a bit confused on how you set up the script in /usr/bin and thought it was somehow connected to this issue.

I am experiencing these crashes on Ubuntu as well. As mcmillan notes, it gives an incompatible version of QT error message.

Cannot mix incompatible Qt library (version 0x40801) with this library (version 0x40800) Aborted

I can reproduce this on Arch Linux.

I tried adding a file and got:

(Scrivener:12974): GLib-ERROR **: gmem.c:382: overflow allocating 1375756650*4 bytes

When I try to click on a playlist (Document reference):

(Scrivener:13000): GLib-ERROR **: gmem.c:382: overflow allocating 1375756650*4 bytes

When creating a snapshot:

(Scrivener:13024): GLib-ERROR **: gmem.c:382: overflow allocating 1375756650*4 bytes

When trying to load a video in my references:

(Scrivener:13046): GLib-ERROR **: gmem.c:382: overflow allocating 1375756650*4 bytes

Edit: I can do all these things on the windows/WINE version. (Videos don’t play, but they never did with Windows/WINE.)

And for the sake of testing, I tried it with and without the plugin set. No difference, same message, same crash. (I don’t need the plugin set to run Scrivener, and I’m using KDE 4.9.1 on my desktop.)

Question: has anyone tried installing the ugly plugins for gstreamer? Reason I ask, Oblivion under Steam crashed in a similar manner (when trying to play an mp3 or a video file) until it was installed.

Hi guys! I see that many of you face unextected problems. I will give you some hints that might make your life easier.

  1. You MUST NOT use the Qt libraries provided from your Linux distribution. Using any of the system Qt libraries for sure will break Scrivener. The only Qt libraries that will work with Scrivener are the libraries bundled and installed with the Scrivener Package inside the …/lib installation directory of Scrivener. Everything else will get you into problems. We compile and link using -rpath to make sure that the custom Scrivener Qt libraries are found automatically, so no user effort is expected here to run Scrivener. Next versions will unset QT_PLUGIN_PATH as we have found out that this causes problems with the plugins. For the time being, please set it manually before starting Scrivener.

  2. Packages that might help you get Scrivener Up and running in case it does not:

sudo apt-get install
libfontconfig1-dev
libfreetype6-dev
libx11-dev
libxcursor-dev
libxext-dev
libxfixes-dev
libxft-dev
libxi-dev
libxrandr-dev
libxrender-dev

Phonon Libraries: doc.qt.nokia.com/main-snapshot/p … n-overview

official library names according to the web site

sudo apt-get install
libgstreamer0.10_0.10
libgstreamer0.10_0.10-devel
libgstreamer-plugins-base0.10
libgstreamer-plugins-base0.10-devel

Ubuntu names of the Phonon needed libraries

sudo apt-get install
libgstreamer0.10
libgstreamer0.10-dev
libgstreamer-plugins-base0.10

#Extra Scrivener Qt Dependancies libs nice to have
sudo apt-get install libcups2-dev

As you might have noticed, most of these are development libs and you should be fine without them. I believe the gstreamer and the gstreamer-plugins libs are the ones most probably causing you problems as they are used by phonon for media functionality. You can try installing them, if you have problems with Scrivener.
We might add and install these packages automatically in the future, but because of the different names, versions on different Linux distributions we are not doing it currently. For now you might install them manually in case you have problems running Scrivener under Linux.

  1. Scrivener is Compiled on Ubuntu 10.10 - 32 Bit. We can use newer version, but it caused problems with users still using old Linux distributions, so we decided to stay with the most basic set of libraries, compilers and distributions.

Hope this helps!

Tiho

I also have the problem of crashing with incompatible Qt libraries when trying to add a file, both in 1.2.6 and 1.5.0.6. The ‘unset QT_PLUGIN_PATH’ command is in my Scrivener startup script, but it doesn’t seem to have any effect; as far as I can tell it wasn’t set in the first place. Am I missing something? I was on the point of trying to uninstall the built-in Qt libraries last night, but I realised in time that this would destroy my desktop environment.

I’m on Ubuntu 12.10 (32-bit), mostly using Gnome-shell; the problem also occurred with 12.04 and Unity.

UPDATE:

It doesn’t appear to crash on Ubuntu 11.10, or on Linux Mint MATE 14.1, even when Qt 4.8.3 is also present.

Hrm…

I know the 64 bit slackware distro uses the same 32 bit libraries and things. I also know that it works fine under 32 bit slackware. Once I’m back on my desktop and we have windows in the apartment, I’ll redo my desktop and see how it works.

I have a theory that either Scrivener has an issue with 32 bit gstreamer on a 64 bit platform, or there’s a library that isn’t getting installed. (There’s no gstreamer dev package for arch linux that I can tell. Hypothetically, everything you need should be in it.)

Using Linux Mint17 MATE 32 bit (ubuntu based)

I can confirm that the crash on snapshot problem still exists. When I try to make a shapshot Scrivener crashes with the message:

Cannot mix incompatible Qt library (version 0x40806) with this library (version 0x40800) Aborted

So far I tried all suggestions mentioned here to make it work but without any success. To summarize:
-tried to add all gstreamer packages with relation to qt
-removed all gstreamer packages related to qt
-installed other gstreamer packaged suggested here (mainly dev)
-ran scrivener as root
-‘unset QT_PLUGIN_PATH’

I have to agree with another user that the option to disable playing the sound alltogether would potentially resolve this issue for me.

Ok I further tracked my issue (Linux Mint17 MATE 32 bit) and could resolve the crash. Basically what I did was removing the following packages:

phonon phonon-backend-gstreamer phonon-backend-gstreamer-dbg phonon-backend-gstreamer1.0 phonon-backend-gstreamer1.0-dbg libphonon4qt5-4 libqt5quick5 phonon4qt5-backend-gstreamer phonon4qt5-backend-gstreamer-dbg python-qt4
Which triggered the removal of some more packages, some of which I will need in the long run, but for now it resolves the snapshot crash bug.

Thanks to an earlier tip, I resolved the “camera-click” problem by deleting the .wav file:

/usr/share/scrivener/bin/resources/camera_click.wav