Crashes when try to print

Have been using Scrivener for Mac for several months successfully but now when I try to print a document it crashes (freezes.) Have to Quit or Force Quit. Thought it was because I had cut and pasted text from Pages but it does it on docs I have created in Scrivener only. Completely unusable right now. Got it to print in compile but not individual documents. Any ideas? (Didn’t see this problem in posts)

MacBook running 10.7.4 OS
Using Scrivener 2.2 (purchased)

Tried restarting computer several times, tried importing .txt and .rtf as well as .doc and .pages files. Tried creating new project in Scrivener (no imports.) Nothing has changed about my printer (Canon MP470).

Found your post today, having similar problem, only no crashes. Mac 10.6.8
Printer is similar as yours, Canon 4350d. Prints fine from within every other app and PDF’s generated by Scrivener open and print fine in Preview.

Instead of a crash, I get a Canon error dialogue: error -30893

Tried uninstalling the print drivers, and reinstalling. No change.

Seems odd, considering this is a Mac program from the ground up. I’ve been working with Scrivener 10 hours a day for 6 days, and this is the first attempt to produce a hardcopy of anything. Very disconcerting.

I am having the same exact problem mentioned in the reply, tried the same remedies, and keep getting the same error message (error -30893). I was able to print successfully from scrivener to my desktop printer with no problem, but now that we’re using a networked printer I get that error message and can’t print. Though if I cut and paste to MS word, that prints fine.

Anyone have any idea what to do about this? I’ve googled around and found no help.

I’m sorry to be a pain, but could someone perhaps give me some advice on where I can search for information on the above problem? Maybe on the bug forum here? Or a Mac or Canon forum? I assume no one’s addressing it because they don’t know the answer, so I’m just wondering if maybe I’m barking up the wrong tree in this form.

mikru: have you emailed support?