Create ToC manually for ebook doesn't work

Hello,
Using Scrivener 3.1.5 (Mac), I am trying to compile an ebook. The auto generated ToC appears to completely miss two sections from the Front Matter (Author’s Note and Maps).
So I presumably have no choice but to create a ToC manually.
This is what I did step by step.

  1. Created a new text file under eBook folder and label it Contents Page
  2. Selected the Dedication and Copyright folders.
  3. Edit - Copy Special - Copy documents as ToC
  4. Pasted in Contents Page text file (noting that each line has <$p> at its end)
  5. Select Authors Note and Maps folders.
  6. Edit - Copy Special - Copy documents as ToC
  7. Pasted in Contents Page text file below the previous two entries
  8. Selected Chapter folders (which I now have to rename as Chapter 1, Chapter 2, etc)
  9. Edit - Copy Special - Copy documents as ToC
  10. Pasted in Contents Page text file below the last entry for Maps

All lines have the <$p> placeholder at the end.
However when I click on Compile and untick the “Generate HTML table of contents”, the contents page appears as plain text with “?” after chapter (Dedication ? Copyright ?, etc)
And none of the lines are clickable.

If I leave the “generate HTML table of contents page” ticked (and write Contents Page in the Table of Contents title), I get an error message with computing jargon (enclosed).

What am I doing wrong? Why does “Copy Documents as ToC” not work?

An auto-generated ToC creates entries based on page breaks. Are the sections in the front matter separated by page breaks?

To create a manual ToC for ebooks and web pages use:
Edit > Copy Special > Copy Documents as Structured Link List (not Copy Documents as ToC).

Does that make a difference?

The above command is what you want to use (there are no page numbers in an ebook, so copying as a printed ToC won’t work). Also note there are other specific rules you have to follow given that this page must conform to ePub specifications internally. It’s a bit picky, and the user manual goes over those details in §22.2.

How can I delete these unwanted question marks from the Table of Contents?


The “Scrivener Manual” discusses the question marks in Section Chapter 22. Perhaps start there to see where you can adjust compile settings for the output format you want (neither did you state here).

For an ebook, it’s “Copy as Structured Link List” and the question marks disappear.

The question marks error is not discussed in the Manual, at least in Chapter 22 of my copy (November, 2020 Revision 3.2.0-01b)

Had you mentioned “ebook”, and and provided compiler settings, I would have answered differently. “Question marks” mentioned on page 550, twice. Of course may not be applicable but working on meagre info here. Glad you sorted it.

Not in my version of the manual.

I’m not at all sure why you are making an issue of this, but look at the top two paragraphs of your screen shot.

At this point, I think we can leave this alone.