Creating Chapter Titles in Scrivener 2021

Hello, new Scrivener user here. I cannot figure out how to change my chapter titles from “Chapter One” to “Chapter 1: [binder name]”. I’ve looked through the forums and I’ve read that article on Scrivener Virgin multiple times, but nothing lines up with the settings I’m actually seeing on Scrivener 3.2.2. The article on Scrivener Virgin is from 2017 and the settings layout looks very different from what I have. How do I use my binder name as part of the chapter heading? Thanks.

Yeah, anything before the very end of 2017 is going to be referencing the old compiler system, which is still fundamentally similar, but arranged in a different way.

In the new system, if you want to customise how your chapter heading looks, it’s pretty easy to do so:

  1. Enter File ▸ Compile....
  2. The first thing to check is to click the Assign Section Layouts... button at the bottom of the preview column in the middle. Scroll through the different variations you can select and see if anything in here does what you want. If so, the matter is as simple as selecting the Type in the left column that prints chapter breaks and then the tile on the right that you want. For many people, this would be the end of the checklist.

So say there is nothing you like in the prefabs—and in your case precisely, there won’t be, as we don’t have any layouts that work exactly like that.

  1. Back in the middle preview column, scroll to the tile that depicts the current “Chapter One” look you’re getting, and double-click on the tile to edit it.

  2. You may need to confirm the duplication of the format, if it is a built-in that cannot be edited directly. Once you’ve done so, you should be staring right at the section you need: Section Layouts.

  3. First, you want to add the binder title, so click the Title checkbox for the highlighted row in the upper half of this pane.

  4. You could go ahead and work on the formatting of the heading in the lower half, but I suggest getting the text output set first. Click on the “Title Options” tab.

  5. What you probably want to change is in the Title Prefix box. You may have to remove a carriage return at the end, and replace it with a colon. The counter style will also need to be changed, from $t (which prints “One”) to $n. Here is an example, using one of the Ebook layouts:


    (Note the small blue dot after the colon is a space.)

  6. You may also want to adjust the Case settings in this tab. The binder title case is in the top-right.

  7. Back in Formatting, use the regular formatting tools (you can use the main Format menu as well) to lay out the title the way you want.

  8. Click Test... in the lower left corner and see how it looks. If it’s all good, save your settings and you’re done.

Excellent, thanks! That fixed the issue. One more question: how can I mark I chapter as an epilogue? I managed to use a different section layout for the epilogue using the same Title Prefix idea, but I don’t know how to get rid of the number. It currently shows up as “33 Epilogue”. How can I make it just say “Epilogue”?

Have you made a Section Type for your epilogue yet, and assigned it to that type with the inspector? If so, then first you need to do is set that type of document to use your alternate Layout (using the first two steps, above). Once you’ve done that, edit the special layout similarly to how we did before, only this time clear out all of the text in the Title Prefix field. That should leave it only printing the title.

Finally figured it out! It took some doing but you’ve made it all clear. Thanks so much!