Crippling import issue: default text style is ignored

I’ve noticed that when I import text files from disk, the come into scrivener with a font (8pt. MS Shell Dlg 2) that is neither in the original file, nor the font specified in my default text style. This seems rather arbitrary. Shouldn’t it at least default to what we specify as our default text style?

Here’s the larger problem that this causes: I import a file, and then need to change the font because this tiny 8 pt. font is unreadable. Ok, so I select the text in the window and change the font from the menus above. But what if I import 100 files? 1000? There’s no Convert >> Formatting to Default Text Style menu option implemented in the Windows version yet, so this becomes paralyzing – it’s impossible to hand fix this many imported files. I could get around it if there was a way to specify the default import font, but as far as I can tell there isn’t.

Help?