Cross-compatibility already in place for 2.0/1.0[NOTED]

Tried opening a document created on a Mac with the Scrivener NaNoWriMo release (2.0) on my Vista-running notebook using the beta Windows Scrivener… and nothing happens. Tried opening it from within the program, and by simply double-clicking on the file icon, but in each case Scrivener for Windows doesn’t respond by opening the document. Is this anamolous to me?

Can you try opening the .scrivx from within Scrivener for Windows itself i.e. via the Scrivener File>Open… menu?

I’d be interested to see if that works when double clicking the .scrivx project file doesn’t appear to.

Lee

Tried that – that’s what I was intending to say that I tried to open the document from “within the application.” Needless to say, it didn’t work…

Have only tried this with one document so far… when time permits I’ll experiment some more, perhaps it’s only a pecadillo of this one doc for some reason…

It may be an issue with that doc. I know that Lee had to write his own RTF parser from the ground up (no mean achievement) and there are still some wrinkles to be ironed out with it.

I have successfully imported a 50Mb+ project from Scriv 2.0Nano to the Windows version with only a few little issues as a result*, so I know that broadly speaking, import should work to some extent.

Eddy

  • Specifically, links to Internet URLs get stripped out, you get some strange characters in synopses and there is a little bug where you may see little numbers in the left column of imported documents. These are all logged bugs at this time.

Edit: I see that the interim release of Scriv for Windows fixes the ‘little numbers’ bug :slight_smile: - viewtopic.php?f=32&t=8944