Curly Quotes for Swedish Users

Hello,
I am a new user and I am addressing a problem that’s been discussed in a previous forum thread:
" [Version 3: Curly quotes follow Scrivener’s UI language, not system settings" (I was not (!) allowed to insert an link to this topic.

I raise the problem again, since the thread only seemed to interest one other Swedish user. There was no support answer.

When I write in Swedish i need to have access to the language specific curly quotes. A solution suggested in the thread mentioned, was to activate Swedish UI, but there is no Swedish UI in Scrivener 3 for Windows. In Options it says: “Swedish - Preview available” and it never changes from English to Swedish. And I don’t think settings like this should be dependent on the software’s UI. There are many reasons for using the English UI, mainly for ease of support.

Does anyone know how to solve this problem?

Best regards

1 Like

How about using a substitution? You could for example define a substitution for >> to “. Likewise for >>.

To do this go to File → Options ->Corrections, then press the “Edit Substitutions” button and create the two substitution rules you want.

Note that sometimes Scrivener does not apply your newly created rules right away. You have to restart Scrivener and then they will be accepted.

Thanks!

Sorry to say. but I couldn’t get it to work.

I am not allowed to attach files, so I can’t show you. (What’s this stupid limitation for a new member?)

I’ll try to explain: In Sweden we use the English second curly quot in both positions. And if I type these characters in the correction box, they turn up as “un-curly” quotes. I can’t find the right characters in the popup box to the right, only the “un-curly” quot.

What do I do wrong?

Best regards

You probably did everything right, except you did not scroll down long enough to pick the right character. Either try it again, or here is another trick: Open your favorite word processor, for example LibreOffice, select the quote character there and press Ctl+C. Then go to Scrivener, open the substitutes table and add the character in the right field via Ctrl+V.

(LibreOffice has a much nicer character table in which you can search by groups. But any other application will do as well.)

You can also use the Alt key and your numeric keypad to enter some common characters. See https://www.tools.oratory.com/altcodes.html

Just hold down the Alt key, then press the 3- or 4-character number on the numeric keypad (not the numbers at the top of the keyboard).

Thanks for your kind help.

At last I was able to find the initial quotation mark in English. I must say, Scrivener do have a character table that’s difficult to read for old eyes. I could find it when I picked ut the name of the character from elsewhere.

But it still made the correction by switching the U+201C (English initial curly) to a U+02BA (plain quotation mark) instead of the curly quot that I specified…

It works with the different characters when I make a “search & replace” throughout the whole project. But not in the correction box. It’s a mystery for me.

Thanks for the suggestion. It’s a feasible work-around.

To anyone working on Scrivener: There must be a way to address this in the software itself. I bought my license since Scrivener has a high reputation as a writer’s tool. It’s so annoying to find that the first problem I encounter, is to enter curly quotes in another language than English. Such a basic feature.

I am almost prepared to change my UI to Swedish if there was such a built-in localization. But as I wrote in the original post: In Options → Language it says: “Swedish - Preview available” and it never changes from English to Swedish even if I try.

That’s interesting. My best guess is that the so-called “smart quotes” feature is interacting here with your substitutions. On the File → Options → Corrections tab and “Corrections” selected in the left column, you find the Smart Quotes option. Let’s see if Scrivener does your corrections right when you turn that off.

It indeed has and I am disappointed as well that such basic typographical things have not been implemented yet. It can’t be that difficult to allow the user to select one language for the project and do the correct substitutions for quotes, hyphens, em- and en-dashes depending on the language setting. This is one of the signature features of a writer’s tool and Scrivener should certainly have that. I understand that the developer team is small and their clientele is not a hundred’s of that of Word or LibreOffice. But those things should be there for sure – especially for a tool of a niche market. (My 2 cents…)

Sorry, still the plain U+02BA even if I turm off “Smart Quotes”. Could the quot character be excluded from “corrections”? Strange thing this.

But it also points out that the software is ready for different typographic adaptations. I don’t understand why there are several options that creates the U+02BA in the Smart Quotes. By the way, it’s very hard to see the difference between the options in the box.

Thanks for your effort!

As for now I have two work-arounds:

  1. To use the keyboard: Alt + 0148 instead of the quotation key
  2. Write the document with non-curly quots, compile the document to MS Word and use its autoformat tool.

My, oh my. I get flashbacks of the early days in computing. :wink:

I just tried the following solution: I defined a substitution of >> to ” and that worked just fine. You just would have to type >> at the begin and end of a quote.

Under the Corrections tab of File ▸ Options..., the first setting in the Punctuation section allows you to choose the smart quote style for both double and single quotation marks. The fifth option down in the double quote dropdown, for instance, sets right quotes for both opening and closing a quote, and the one above that uses double right-pointing angle quotes. You’ll need to have the Use smart quotes option enabled to select and use these.

The language setting for the interface (in the General options) doesn’t affect your text in the editor; that’s just about the language used for the menus and labels. So you can leave that as English but still have other settings optimised for the language you’re writing in.

Thanks, at last I got it to work. Lovely!
I thought I have tried every option in this dropdown list, without finding the right one. But I must have missed the one I wanted.
I had great problems to actually see what kind of quot character was my preferred. The glyphs are too small for old eyes. The same goes for the character map. 10 years ago I would probably have spotted the right one at once.

Thanks everyone: NorbVor, BClarke and MimeticMouton

Best regards

Very welcome @matzah!

Take also a look at this post, which explains which smart quote is used in which language:

Thanks!!!

Best regards