Current line highlight is incomplete

Recently–don’t know exactly when, but no new versions of Scrivener Mac loaded–the current line highlight quit working as expected. Only the ends of the current line (right and left, where there is no text) are highlighted; the line of text itself is black print on a white background with no highlight. A screen shot is attached.

If I hit a CR to create a new (blank) line, the highlight extends across the page as expected until I begin typing, at which point only the ends are highlighted, as described above.

The highlighting checkbox is ticked in both the editor and compose preferences.

If I open a different project, the highlighting works as expected.

I’m using v2.5 (25239) on a Macbook Pro Retina and have tried the following to fix the issue, with no success:

-restarting scrivener
-closing the project and reloading
-closing the split window view (didn’t help) and splitting again (problem persists).
-restarting my mac
-unticking the highlight checkbox (highlighting goes away) and re-ticking it (problem persists).

Thanks,

Jim

It must be invisible on your display, but I can see a very light grey highlight behind all of the text in your screenshot. If the are no other highlights in this document, then simply select all of the text, and right-click on the highlighter tool in the Format Bar, selecting the tile with the red slash through it, to remove highlights.

Thanks, but I think that’s an artifact of the screen capture. I had to dial the quality back to 50% to get the image into the right size range.

Or, now that I think about it…

I have the page background set to a very light gray. I think that’s what you’re seeing.

But I did just discover something else about the issue. Will post that shortly.

Just learned something else related to this issue.

As shown in the screen capture, I have the screen split into a locked outline of the last chapter of my book on the left and the manuscript on the right (great, fantastic feature, BTW).

If I click on a scene in the outline view, the highlight appears as expected and all is well with the world.

If I click on the same scene in the binder, the highlight appears as I described in my initial report.

This fits with the timing of the problem, because I only started using this layout recently to help me through a complex time sequence and only recently noted the problem.

So, if there is a bug, it’s a hinky one, only happening when selecting sections to edit from the binder while having a split screen open to an outline.

Whew.

Jim

I’ve recreated your setup and I don’t see the (yellow) current line highlight running through the text no matter how I get the document to show up in the editor if the text itself is highlighted, but it definitely seems like you have a light grey text highlight going on, rather than a light grey page background.

Did you set the grey background color in the Formatting pane in Preferences or in the Format Bar? The right place to set the page background color is in the Appearance pane, under the Customizable Colors section, and further under Editor > Text Background. If I were you I would follow AmberV’s advice on getting rid of the text highlight.

Quick question: does this happen if you switch off Page View in the right editor? I’m wondering if it might be a display glitch related to that feature. It definitely looks like text highlight though. Here is an exaggerated example I created to demonstrate the different settings you can change in the Appearance pane, along with what formatting based text highlighter will look like:


And now here is your example, edited to dramatically increase the amount of contrast at the brighter levels:


I just wanted to point that out, given that you said your “paper background” was light grey, and it is very definitely white, not light grey, it’s worth double-checking your settings. All of the black-labelled settings in my example above are found in the Appearance preference pane, in the “Editor” section, by name. The one red label is text formatting, not a preference—though I suppose it would be possible to add a text highlight to your default text, in the Formatting pane, but there is very rarely a need to do that.

And maybe in those settings you’ll find changing something causes the bug to vanish, if it isn’t just rogue text highlighting. If it is though, I don’t see why loading it one way or the other would make a difference.

Well…

Thanks very much for all the time you’ve put into this, especially the illustrations. Couple of things to report, along with a resolution, albeit a somewhat confusing one.

I selected the text and killed the text highlighting via the formatting pane, even though I couldn’t see the highlighting on my Apple Display monitor. Bingo, the current line highlight looked as it should.

The current line highlighting is fine if I either delete the text highlighting by clicking the circle/slash option in the top left of the formatting pane or if I select the first choice to the right of the circle/slash. Any other selection and the current line highlight looks like the illustration you provided (and like my problem report) – it appears the text highlighting trumps the current line highlight. That’s not what I’d expect, but it’s understandable and reproducible.

So, it appears I did have a text highlight in place, even though I couldn’t see it and don’t recall setting it.

For what it’s worth, once I cycled the text highlight in the formatting pane as described above, I could see the subsequent text highlights just fine (excluding the choice to the right of the “cancel” checkbox, which I presume is white and the same as no highlighting). Go figure.

I also confirmed that changing from Page View had no impact.

Again, thanks to you both. Sorry for the fire drill. It’s hard enough to solve some tech support issues, much less those that are invisible.

Think I’ll schedule an eye appointment.

Jim