cursor and two t's at the end of a word

I found a curious bug replicated by the following steps: [Note: for the following example I will represent the cursor with an *]

  1. type “dontt” (without quotes, obviously)
  2. press the left arrow key one time (the cursor now appears to be located at “don*tt”)
  3. press the spacebar (you will get “dont t”)

In other words, although it appears that the cursor is located at “dontt" is is actually located at "dontt”; for some reason the DISPLAY treats “tt” as a single letter, but whatever is going on behind the scenes knows that they are really two letters. Does that make sense?

If, for step #2 above, you press the left arrow key TWO times, the cursor still appears to be located at “don*tt”

This occurs with any word with two t’s at the end.

I’m loving Scrivener; thanks for all your hard work!

I tried to reproduce this one but cannot. Using left arrow keys works properly for me only advancing one step at a time.

I run Win XP Home 32bit with service pack 3.

Hmmm, I’m running Windows 7; perhaps that has something to do with it?