Cursor changes size

Hi, guys!

Often, when I type Enter, the cursor on the new line becomes only half the expected size. It immediately reverts to correct size as soon as I start typing, so this isn’t really a problem, more like a nuisance.

I am using version 3.3.6 and Sonoma. I am also using 200% zoom.

As I said, it isn’t really a problem, as everything works! I just thought you’d like to know …

What font and line settings are you using?

Exactly, that’s what we need to know, as the cursor has been extensively looked at thus far and this is a new description. The values as printed in these tools:

  • Format ▸ Paragraph ▸ Line and Paragraph Spacing...
  • ... ▸ Tabs and Indents... (for good measure, who knows if a first-line indent in combination with another odd setting is necessary).
  • The font family, size and variant (Roman, Italic, Semibold, Black, etc.) in use.

Any other contextual editor settings that might be notable. Page View, Line Numbering, Show Invisibles, Vertical Layout… that kind of stuff. Zoom you already stated, that’s a good one to know.

Lastly, if you create a new project using the “Blank” starter and type in a few lines, does it occur there? If this project uses different formatting, if once you implement that formatting into it, does it start happening again? You can do this very easily by:

  1. Copy and paste a paragraph from your project.
  2. Use the Format ▸ Make Formatting Default menu command, selecting the option for “This Project Only”.

If that reproduces it, then use File ▸ Back Up ▸ Back Up To... with the zip option enabled, and drag and drop the .zip copy of this test project into the response window here to attach it. We’ll take a look at it directly and see if it reproduces. Note that if these are your global formatting settings, we won’t have them, so do use that second command listed above to set them into the test project before sending it, otherwise we’ll just see Palatino or whatever.

1 Like

I am using 12 pt Palatino and 1,5 line spacing. I have ALWAYS used that setup in Scrivener, but the issue at hand has only showed up quite recently – never before!