Cursor is a long black line...[BUG LOGGED]

I decided to try hitting alt+enter in Scrivener in case it was a fullscreen shortcut (as it is for many things in Windows). It didn’t toggle any sort of fullscreen mode, but it did mess up my cursor, which is now a long, blinking black line. I also hit ctrl+enter and possibly a couple other key combinations, but I think the problem occurred when I hit alt+enter. Nothing I’ve tried has fixed it. No keyboard presses or combos, not closing and restarting Scrivener, not restarting the computer, not even uninstalling Scrivener, deleting the Scrivener appdata folder, reinstalling it, and replacing the executable with the updated version from 10/29. And it happens in both the project I’m working on and any other Scrivener projects I open up. The problem doesn’t seem to be endemic to the system, though, since it doesn’t occur in Word, Notepad, or anywhere else I’ve found.

See the image below - I blurred out the text with GIMP to spare you guys my horrendous NaNoWriMo scratchings, but the long black line is the blinking cursor. It does the same thing in fullscreen mode, as well. Sorry it’s so tall…

I’ve actually had it happen to me as well, though I wasn’t using any key combinations. I was working in and out of the full screen mode trying to get my text to look the way I wanted it too. (It was as if it had aligned left leaving nothing on the right side) when suddenly my cursor turned into that large black line. I tried closing scrivener and then starting it again but it’s still there.

The long black line is called a block insertion point. You can turn if off and on via Edit->Options->Editor->and checking/unchecking “use block insertion point”.

However, having said that, I’ve noticed that my cursor will sometimes change to a block insertion all by itself, so I suspect there’s a bug there. I haven’t paid attention to any kind of pattern-- I just notice it’s changed and change it back.

Okay thanks for that. Though I don’t remeber ever selecting that option. What you said is probably correct and I’ll be watching to see if it comes back on. Thanks again.

Same with me. I did not activate it in the editor preferences but suddenly had the block insertion cursor. Got rid of it via editor preferences.

Ciao Markus

I am unable to turn off the “block insertion point” option. I uncheck the box, hit apply and or ok, and the blinking black line remains. When I go back to turn it off again, the box is already checked. It simply will not stay unchecked.

This happened the first time I went into the edit options, to try to turn off the capitalization after a period default (very annoying).

Please help!

Thanks, Thomas

I uninstalled and then reinstalled 1.3 When it came back up after the reinstall, the black line was still there. However, now the program permitted me to turn off the block insertion option. Strange that it would not let me do so before.

What a relief. I love this program, but I could not coexist with that blinking black line.

I had this same problem. It was the biggest problem I had with the entire editing system. Of course, I haven’t got to the actual compiling portion yet.
I was frustrated by the blinking line at every turn, but I just let it go. Eventually, it went away seemingly on its own. I didn’t check or uncheck anything in Edit>Options>Editor
However, I was still curious, and I went online to find out what it was all about, or to report the bug. I found this list of posts, and decided to see if it worked like that in what ever version I have. That was before I saw the one about it getting rechecked. So now it won’t go away in the same way that Thomas has to deal with.
Curiosity killed the cat… :blush: But I’m not going to reinstall. It took me literally a month to get it installed in the first place, thought that’s only because I kept making mistakes between Mac and PC.
So yeah… Black bar= :imp:

This is happening to me, as well. I’ve tried un-checking the Block Insertion stuff but it doesn’t save my change.

I have no idea why this started. I hadn’t changed anything that I can think of. It just started doing this out of the blue.

I upgraded to 1.4 and the black line went away. It was great.

Then last night, I started up Scrivener and went in to change the Corkboard settings to change the corners and things and when I came back out to start writing, the black line was back.

The line is really, really irritating and makes it difficult to write.

Besides showing up in the edit window, it also shows up in the Document/Project Notes window. It does NOT show up in the Synopsis.

I’d like for this to have a high priority on the fix-list. :slight_smile:

It’s ironic, you can’t get rid of it because it won’t save your Block Insertion Point setting being turned off, and I can’t DUPLICATE it because it won’t saving my turning ON the Block Insertion Point. I want to tell you to try to revert back to your defaults in the Options menu, but I can’t remember if the Block Insertion Point was a default on or default off setting. I want to say off because I never turned mine off it was always off. So it is worth a try.

OK. Weirder and weirder. I just went in, turned it off… and it STAYED turned off. Now it looks fine. The block is gone.

Well, at least until it’s figured out you don’t have to suffer. Whatever you do, don’t mess with that setting again! :laughing:

I’m using Beta 1.4
This black line appeared out of nowhere for me, again. And it won’t go away. The “Use block insertion point” box won’t stay unchecked.

The black line remains even after a restart of Scrivener.

I admit to some curiosity as to why the ‘block insertion point’ even exists. Under what circumstances would you want to have a giant black flashing line instead of a cursor?

I was looking forward to participating in this process. But if I can’t use the program to write, which is the case here, how can I help test it?

Edit: K, immediately after restarting the program again I went into the editor options, unchecked the box, and it stayed unchecked this time. I’ll try to figure out what causes it when it happens again.

I was able to fix this by saving my preferences and then editing them with Notepad. The “TextEditing\cursorWidth” was set to some huge number 17nnnnnn? I set it to 1 and then loaded them, in Edit–>Options and saved. The cursor returned to normal.

I just had the long black line problem for the first time with Scrivener 1.4. After reading everyone’s post, and trying numerous times to uncheck “use block insertion point”, only to have the program ignore me, I exited the program, then brought the program back up. At that point the long black line was still there, so I went into the Edit -> Options box and changed the number of pixels in both the ‘block width’ and ‘editor margins’ to 1, then unchecked ‘use block insertion point’. And my preference was accepted :smiley: !!
'Cause that was going to drive me just a little insane :confused:

Good luck all–I’ll be back if it happens again!