Cursor on Windows 3.1.3.0

I just installed Windows 3.1.3.0. Now, on a new line, the cursor doubles in length. What’s with this? It’s distracting. Is there anyway to make it stop?

Not seeing it installed upgrade today, are you in a different mode like screenwriter’s and is this with every project.
the only thing I see is the cursor will increase in legnth to match line of text. Is your formatting changing to a different size when you go to a new line??

I don’t have a solution, but I’m just commenting to say that I’ve been having cursor issues since updating to 3.1.3.0 also.

I have windows 11 pro version

Thank you for your replies.
It seems to be a placeholder. If I move to a new line and then move the cursor elsewhere in the text, a cursor-sized bar remains at the start of the new line from where I left. I suspect I could turn it off if I could find the option. No luck so far.

I’m seeing some new cursor artifacts as well. Folks, please post screenshots if you can. I’ll do so myself when I’m home tonight.

1 Like

The behaviour I’m experiencing feels like a bug rather than a feature. As well as the extra long line on new paragraphs, I’m also getting “remants” of the cursor remaining on screen if I use the arrow keys to move the cursor. I’ve reported this as a bug at Bug Reporting | Literature and Latte and have linked them to a screen recording I took.

For the record, the screen recording is here: Dropbox - scrivener cursor bug.mp4 - Simplify your life

(Naturally, as soon as I started recording my screen, I started misspelling every other word!)

2 Likes

Yes this is the exact issue. Thanks for reporting it. Hopefully, we’ll get it fixed.

I’m sure you mean the cursor is double the usual ‘height’. Mine leaves a residual dot at the top of the cursor after pressing enter and before typing on the new line as the cursor flickers on and off, as per normal.

Thanks for the clip, @gaving. Surprisingly, my issue is completely different from yours, except for the fact that it also involves being at the the start of a new line. What I’m seeing is a sort of vestigial cursor that comes and goes as I’m writing.

To reproduce -

  1. Launch a fresh copy of the Tutorial.
  2. Select START HERE.
  3. Click inside the editor, at the end of the first paragraph.
  4. Press Enter to start a new paragraph, then press down arrow twice to move the cursor into the following paragraph.

The vestigial cursor is left behind at the start of the new paragraph. See it under “you’ve” in the screenshot below. This is the issue. Start typing somewhere else and it usually goes away.

Other operations will also cause this to happen, for instance deleting letters back to the start of a paragraph. See it over “and”, below.

This also happens in Composition Mode.

L&L support, if you have difficulty reproducing this, please let me know if there is any additional info I can provide. I’m on Windows 10 Pro, Build 19045.

Best,
Jim

It looks like the developers are aware of this issue and it’s being worked on. If you change the line height of your text in the main editor to 1.0, that should mitigate the issue until we get an update out to fix it.

Using a block cursor makes this worse. If you can live with a normal cursor width, you will see less artefacts left behind the cursor. You can disable the block cursor in File > Options > Editing > Options > “Use block insertion point width”. Will do our best to improve this in the next update.

3 Likes