Custom color settings not taking effect

I’ve used Scrivener for quite a while and have never encountered this issue before. In the full screen editor, I like to use an old-school scheme of white text on a blue background. I’ve made the changes in the APPEARANCE panel just like I have before, but no matter what I do, I only get the default black text on white background. Running 2.4.1.

I can’t reproduce this myself. In cases of preferences oddities, it’s often a good idea to reset your preferences to make sure there are no gremlins in the .prefs file. The following procedure will do so in a way that preserves your settings.

  1. Go to the main preferences panel in Scrivener and use the [b]Manage...[/b] drop-down menu to [b]Save All Preferences...[/b], which will create a file on your computer that can be set aside as a backup of all your settings (this may not be important since this is a new computer; you may just skip this step).
  2. Close Scrivener if necessary.
  3. Navigate to your [b]~/Library/Preferences[/b] folder. On Mac OS X 10.7+ you can hold down the Option key while clicking on the Go menu in Finder to find the Library folder.
  4. In the Finder search bar for this window, type in “scrivener2” and make sure the search bar is set to search in Preferences for File Name.
  5. You should get one or two search results; drag and drop to move this file to the system Trash:

com.literatureandlatte.scrivener2.plist

  1. Launch Scrivener.

Now with everything at vanilla default, try simply enabling the “Use different colors in full screen” checkbox in Appearance, scroll down to “Full Screen” in the colour list, and set a “Text Background Color” and “Text Color”, with “Override text color with color” enabled, naturally.

Now load a sample project and hit Ctrl-Cmd-F to enable full screen mode. Does this work?

If so, try using the [b]Manage...[/b] button to load your settings back into the software, make sure things are still set up correctly in Appearance, and try again.

Thx much for the thorough reply, Ioa. I found the specified .plist quickly enough, but am unable to trash it. In fact, I can’t do anything to it. Can’t drag it anywhere. Can’t even bring up a context menu for it. Scrivener is definitely not running, and the Get Info panel shows that the file is not locked. Ideas?

I would try rebooting and see if that fixes the Finder, that doesn’t sound like a normal permission problem or anything of that nature. If it continues after a reboot, then try enabling the Console and watching for error messages when you attempt to access the contextual menu—also trying to access it for other files in your home folder.