Custom compile settings won't stick

I tried to create a custom compile configuration in order to get rid of all the weird Courier fonts and sizes. I went through every line and level and set things to simple Arial 12 pt font (painful, it needs some sort of global ability to set the font).

At any rate, I gave the compile settings a name and saved them. Unfortunately every time I use it, there are still lots of places where the weird old Courier fonts and sizes still appear. I have gone back through each line and level, highlighted the areas on the screen still showing Courier and changed them to Arial, the view area on the screen shows it as Arial when I’m finished. But when I compile, it still uses Courier.

I have done this three times, trying various different possible things. Looking up compile in the help file has not helped, as these specific configuration settings are not described in detail, or I can’t find them.

I can’t use this product if it won’t export/compile a clean, consistent stream of text I can work with. What I would really LIKE to do is set up the levels of the outline to match certain Word Template styles, so when I compile, I have a clean Word doc that is basically formatted correctly. But judging by how rudimentary the functioning and formatting seems to be right now in Scrivener, that seems like a long way off.

Have I found a bug, or am I missing something? How can I get the compile setting changes to stick?

Frustrated in Atlanta

Compile has a lot of functionality and should certainly be able to output a document using a standardised font and formatting–that is one of its main purposes, allowing you to separate the output formatting from the font and formatting you use when working. While Scrivener doesn’t use Word’s templates, obviously, you can still set up a lot of formatting for different levels and so forth so that they either match the template formatting or so that you can easily identify them and format them with styles in Word after compiling. We also do have plans for adding a “Quick font override”, which will, as the name suggests, allow you to just set a single font to override everything, useful for when you don’t need distinct fonts for various parts of the output.

For the particular trouble you’re having here, it would help a lot if you could give us more details about where the unwanted Courier is appearing–it’s not going to be random, and knowing that it appears just in titles or just on documents that in the binder also contain subdocuments or suchlike would help us sort out where to apply changes to the setup to get the formatting you want. Screenshots of the binder showing the expanded Draft folder and of the Formatting compile pane would help as well. Without anything else to go on, the two things I’d suggest double-checking are

  • whether you have set some documents to “compile as-is” (so they are maintaining a Courier font from the editor) – this is easily scene in the Contents pane of compile

  • whether you have enabled “override text and notes formatting” in the Formatting pane of compile – if this isn’t set, the changes you make to the formatting there won’t be applied for the main text

OK, thanks for the suggestion. I had to search the Scrivener help project for “compile” to find places where this stuff was described. Then, it wasn’t too clear. The problem is it is hard to understand the whole compile configuration issue: Lots of confusing things in this nested dialog box arrangement (Frustrating):

Folders, “text groups,” and “text documents” are all called Level 1, 2, 3 …
Clicking on “Modify” lets you change something, but not font which is one of the most important.
I had to guess which one was font, which requires a third dialog
Then, you can’t remember which level you were on (you can’t see it), and neither dialog tells you
Then when you pick your font, it requires cumbersome scrolling
When you attempt to modify a font, and do a compile, you learn it doesn’t modify everything
You have to select the “title” as well as the “text” inside Modify to get them to change.
I’m wondering why this dialog box is so small.
Who knows what “section lay out” is or means
Then when you try to save the compile you learn it might be called “Preset”
So when you have to save a preset (to save the compile config) you have to give it a name.
Only you are updating the one you were working on, and can’t remember exactly what you called it.
So you have to give it a new name, cuz it is not a normal method of saving and naming the file.

Heck, all I wanted to do was get rid of Courier and standardize on Ariel. Took me a huge amount of time cuz the only way to do it was to go through every detail, and details within details. I was being forced to look at the document through a soda-straw with no ability to see what the “Big picture” or end result would look like. SO it took me four or five tries (eight or nine in all since I first tried to do this).

Why can’t I see a full sized “Compile Preview” (like a “Print Preview” in Word) on the right side of the screen, and have the Compile Controls all in one easy lay out on the left side of the screen, so as I turn things on and off I can scroll through the preview to see what it looks like?

Don’t mean to whine, but itsa lotta trouble for something that is supposed to save me time. I’m still not feeling the love yet with scrivener.