Custom Metadata

Does anyone know how to use custome metadata in Scriv3? In Scriv2, I was able to insert pictures for my chapter headings. I would put the photo in the research folder with a particular name, say, P (for prologue) and then I would put in the Custom Metadat spot and it would use the picture instead of PROLOGUE. Like this:

Hi,

Custom Metadata and the <$img…> tag both work much the same as in Scrivener 2. However, the way Compile Formats are put together has changed. We have a transition guide that should help you move over to Scrivener 3 from your old settings here:

literatureandlatte.com/scri … date-guide

This goes into a lot of detail on how to adapt the Compile settings of a Scrivener 2 project to a Scrivener 3 project, including how to import your old settings.

Once you’ve gone through that, if you’re still stuck, please post exactly what you were doing in Scrivener 2 to achieve this and we can explain how to do the same in Scrivener 3.

All the best,
Keith

I didn’t see anything in there on what I’m trying to do.

I think it’s no longer able to put pictures in that way. Am I correct?

No, you are not. :slight_smile: Scrivener 3’s Compile can do everything possible in Scrivener 2 and far more besides.

Did you go through the transition guide? You say you didn’t see anything in there on what you are trying to do, but that wasn’t my point. Did the project whose Compile settings you are currently trying to adjust have all of this set up in Scrivener 2? Or did you create a Compile preset in Scrivener 2 for these settings? If the answer to either of those is yes, then the transition guide will show you how to import those very settings and convert them for use in a Scrivener 3 project. That would be much easier than starting from scratch.

So, if the project had Compile set up to do this in Scrivener 2, then please go through the transition guide to see how to import and convert them. If it didn’t, then please describe exactly how you did this in Scrivener 2 and, as I say, we can tell you how to do it in Scrivener 3. First, though, be sure you are familiar with how Compile works in Scrivener 3 - with the way you edit and create your own Compile Formats, and with how Section Types and Section Layouts work together (all of which can be found in the updated Scrivener 3 tutorial and in some extra detail in the transition guide).

It’s difficult to help without more details of how you did this before. My guess is that you had a custom metadata field that provided an image name and then a title prefix in Compile that inserted the custom metadata using something like <$img:<$custom:metadataName>>. This is all possible in Scrivener 3 using Section Layouts, which replace the formatting levels of Scrivener 2.

I really need your help. I’ve read over the file you sent and I don’t see what I need to do. I’ve made screen shots of my Scrivener 2 project to show you how I was able to accomplish what I needed. Maybe that will help explain better what it is I’m trying to do with Scrivener 3.

I set up the Title Prefix and place the name of the image file in the appropriate metadata spot:

Then I place the image file in the research folder:

This is how the eBook will look to readers:

The screenshot you show wouldn’t have achieved inserting an image, so there must be something else in your Scrivener 2 project that handled that. But then the “Title Prefix and Suffix” that you show in your screenshot are for top-level folders, whereas the “Prologue” document is text. So I would take a look in your the “Title Prefix and Suffix” settings for text documents in your Scrivener 2 project - that will probably show you how you did it.

But looking at your project:

  1. You have a custom metadata field entitled “Image” into which you are inserting the name of an image. In the screenshot, “Prologue” has the “Image” metadata set as “P”, which is the name of an image in the Research folder. So far, so good.

  2. If you want to insert that image during the Compile process, you need to add the following title suffix:

<$img:<$custom:Image>>

In other words: Insert an image that uses the name set in the “Image” custom metadata for this document.

You set this in a Section Layout, and that Section Layout must be applied to your “Prologue” document, or whichever documents should show such images. This is done by setting Section Types for documents and assigning the appropriate Section Layouts to those Types in Compile.

All the best,
Keith

Okay, now I’ve got the pictures that I want showing for the Chapter Titles, but now I cannot get the text of the document to show below. Should I use CHAPTER TITLE to set the image in the layout and use CHAPTER for the text? I have everyting labled as chapter in the documents.

I’ve figured it out. Thank you for your help.

Great, glad you have it working!

Sorry, one more question. I have set up in one manuscript 3 books (a trilogy.) Is there a way to change the title prefix (image) for each book? Or do I have to separate the books into different files (manuscripts?)

I think I’ve answered my question. I think the easiest way is to create custom formats, say…BOOK 1, BOOK 2, and BOOK 3. Then I can save a different picture under each prefix and just choose the appropriate one when compiling, correct?

You shouldn’t need separate formats for this. Just to clarify, are the following assumptions correct?

  1. You have each book as a subfolder of the Draft folder.

  2. To compile a book, you change the Compile group in Compile to export only, say, the “Book 1” folder as though it were the entire Draft folder.

  3. At the start of each chapter, the title prefix uses an image that should be different for each book.

Assuming the above is right:

  1. Give each title prefix image the same title as the book folder. So, for instance, if the “Book 1” folder is entitled “Book the First”, then also title the image you want used in title prefixes for that book “Book the First”.

  2. For the title prefix in the Compile Format, use:

<$img:<$compilegroup>>

If the Compile group is named “Book the First”, then this will get resolved as <$img:Book the First>, meaning that if there is an image in the project using the same name, “Book the First”, it will be inserted as the prefix.

In this way, you can use the same Compile Format, but have a different image inserted before the titles of each book.

All the best,
Keith

I cannot seem to get that to work. Can you take a look at the pic and tell me if I’m doing something wrong?

It’s not working because you have the compile group set to “Manuscript”, and you don’t have an image named “Manuscript”. You need to change the compile group to “Book 1 Ka…” (I can’t quite read it) to get it to work, as that is the whole point of using the <$compilegroup> tag.

FAN-F**KIN-TABULOUS! Thank you so much! That did it and I really learned a lot about Scrivener 3!! :mrgreen:

Great! Glad that got you sorted! I hope to write a blob post about this sort of usage at some point, as I think a few users will find it helpful.

All the best,
Keith

That’s a great idea! Writers can really customize how their books look.