Custom Project Backups

I’m new to Scrivener 3, and right now I have three projects on the go. I saw in the Project Settings tab that I can set it so that each project backs up to their own custom folder. I have done this, but it seems that the global setting still overrides the project settings, and saves all the backups in the main backup folder.

I’m not sure if I am doing something wrong or if this is some sort of error. Any thoughts?

Did you possibly try to set it to put the backups in the same folder where you save your project?

The only thing I’m aware of that would cause that to happen is if the designated backup folder does not exist. In that case Scrivener will fall back to using the central backup folder.

Other problematic scenarios will produce warnings. For example if the working project is stored in its own backup folder you will be warned when loading it, but backups will still be operational. If the folder does not have read/write permissions then you will get a warning when a backup is attempted, and it will simply fail rather than using the central location.

No, the file is saved to Dropbox and the backups are saved locally.

The folders are there. I can move the backup files into them manually, so they seem to be working ok. And if I set the global setting to the project folder, then it works fine, but it also puts the backups of the other projects in that folder.

It’s strange that it just reads the global setting and seems to ignore the custom project setting.

That’s very strange. To eliminate any ambiguity, and look for any potential error messages, I’d try a simple test:

  1. Restart Scrivener with no projects open (hold Shift when launching).
  2. Set Show internal error alerts, in the General: Warnings preference pane.
  3. Open Console.app, from the Applications/Utilities folder.
  4. Next create a new folder on the Desktop called “Test”.
  5. Create a new blank project on the Desktop as well, and set it up to use the “Test” folder.
  6. Type in a word or two and then use File ▸ Back Up ▸ Back Up Now.

Check to see where the backup went, and if it went to the wrong place again, examine Console (it will help to search for “Scrivener”) for any potentially relevant messages.

Thanks, I will give this a try. :smiley: Haven’t had a lot of time to fiddle with it the last few days, but I will update when I have tried this method.

Ok, I have tried all the steps. It did put the backup file in the wrong place again. Looking at the Console (which is all greek to me) the only thing that seemed to stick out was this message:

[WARNING] client can’t fetch all containers by ID (isContainerProxy: NO, isNotAppSandboxed: NO)

And I have no idea what that means. :confused:

All right, I take it from Apple’s odd double-negative statement that you’re using the version sold by Apple, through the Mac App Store? Otherwise sandboxing will be irrelevant. This really should be happening automatically when you select the backup folder (in itself a declaration of permission to use this folder), but let’s double-check to make sure:

  1. Use the menu command Scrivener ▸ Authorize Folder Access… menu command.
  2. Manually add the test backup folder location with this tool. Optionally: select your entire user folder to give Scrivener unfettered access to your files.
  3. Save these settings and then try to save a backup from the test project.

Yes, I think I did purchase it through the Mac Store. I wonder if that is what is causing the glitch.

I did try your suggestion, and unfortunately, nothing changed. The backup still went to the main backup folder.

I want to thank you for walking me through all of this. I’m not really a tech person (I can follow instructions, but that’s really about it), but I am learning a lot.

Hello, DreaCros.

Did you upgrade from Scrivener 2 to Scrivener 3?

As a test – to check if Scrivener can access the custom backup folder at all – can you get Scrivener to use the custom folder for all of your backups, i.e. setting the custom folder to be the default backup location in the main Backup preferences? If it works, we will know that Scrivener can access that folder and that there isn’t a general problem with permissions (you can always reset the backup preferences afterwards).

Hello, Ioa,

If DreaCros has upgraded from S2 to S3, is it possible that an old preferences file is holding sway, similar to the issue described in this post:

literatureandlatte.com/foru … 57#p274457

Slàinte mhòr.

No problem! It’s what I do. This is a weird problem as you might have guessed, so I’m trying to narrow it down by looking for any clues. So far we haven’t found anything terribly useful, unfortunately.

Although I think we’ve eliminated any sandbox weirdness. There is one other measure we should try along those lines:

  • Rename Scrivener in your Applications folder, like “Scrivener-MAS”, and then download and install the direct-sale version.
  • Run that by double-clicking from Applications, and verify you are running the direct-sale version by checking the Scrivener menu. The “Authorize Folder Access…” selection we used before should be missing (the direct-sale version isn’t sandboxed and doesn’t need it).
  • Install that into Applications, and to start with I’d leave things factory default with the backup folder set to the Library folder, where it suggests. You can open up that location from the Backup pane.
  • Next do the same test as above with the “Test” folder on Desktop.

If that works you might consider switching to the direct-sale version. You’ll have noticed that you weren’t asked to register, it will check for your receipt from Apple. Here are some instructions for getting your settings moved over.

We’ll have to check and see if there is a general problem with the App Store version in that case.

If it doesn’t work, then feel free to switch back, by removing “Scrivener” and then renaming “Scrivener-MAS” back to “Scrivener”.

It’s not a bad idea, but in that case it wasn’t Scrivener using the wrong preferences (I don’t think that’s possible) but macOS itself, specifically for how it stores and sets custom keyboard shortcuts.

That aside I think the main problem here is that individual projects are not storing their backups where designated, and are using the main custom backup folder in Preferences. So that part should be working fine on its own, it’s the ancillary backup location that is being ignored.

It worked! Thank so much. I will definitely switch over to the direct sale version. Thanks again :smiley: