Custom styles behave oddly syncing between iPhone & Mac

This issue is similar to several mentioned below, but not identical.

I have a couple of custom styles set up on my Mac that I use in my draft, called “Body” and “Body 1st paragraph”. When I edit a document on my iPhone (which I do regularly, since I often have ideas as I’m walking to the bus stop in the morning!) and then sync it back to my Mac, some or all the paragraphs have changed to a different style.

I haven’t done enough testing yet to work out the exact sequence of events, but since the style menu isn’t available on the iPhone, it’s clearly not anything I’m doing on the iOS end.

I’m using Scrivener for Mac 3.0.3 and the latest version of Scrivener for iOS.

Hi, Redfox!

I gather that you use styles throughout your project, that is, that you have no text that doesn’t have a style applied. In general, Scrivener assumes the opposite: that styles are used only for exceptional cases such as block quotes. You may well already be aware of this (it’s discussed in section 15.5.1 of the Scrivener Mac manual) and have thought it through :smiley: , but the downside of having all text styled is that you are always swimming upstream against Scrivener’s design and have in particular guaranteed that you will need to work harder when it comes time to compile your project. Your choice, and I’ll continue by assuming that you’re going to keep styling everything :smiley: .

I can’t say that I’ve encountered this problem in my own work, as I’ve long since adapted to having mostly unstyled text. One thing I would check ( and you may well already have looked at this and know it’s not a problem) would be fonts. If you’ve included a font in your styles that iOS doesn’t have, iOS might mess up. If you think this might be a problem, here’s an article on how to address it:

The next thing I’d check would be how my styles are set up on the Mac. In particular, do you have Next Style set properly? I’d assume that you do, if you’re typing along on Mac happily, but it might not hurt to check. (if I were setting up what you described, I’d have Body 1st’s Next Style be Body, and Body’s Next Style also be Body)

Finally, contrary to your impression, Scrivener on iOS does have a style menu. You can’t create or modify styles on your iPhone, but you can apply those you’ve set up on your Mac. This is described in the Editor section of the iOS tutorial. Here are a couple of screenshots showing how to access it:

Hope this helps!
[edited for clarity]

I’ve been using Scrivener since 2007, and thus only read the manual when I get stuck on a feature that’s changed between 2 & 3 :slight_smile:

I like being able to style my text on the Mac to look exactly how I want it to when I’m writing. That’s the whole point of Scrivener’s “Compile” mode, right? However if it’s going to keep switching things around, I guess I’ll have to resort to changing the default font. You’re right, though, that I did have issues when compiling until I added my custom styles to the relevant places.

I don’t recall having any compilation issues in version 2, but maybe I didn’t create custom styles before. ::shrug::

Nope, just using Optima and Palatino, which are available on iOS according to a quick Google

Yep, done that already.

Ah, thanks for the reminder - I’ll look into that. I mostly just type on iOS, so I haven’t really poked around in all the menus.

I’m glad to be of help! It’s hard to gauge someone’s experience from 1 post :slight_smile: and not even the date they joined the forum is always meaningful, so it’s a tightrope walk between being patronising and assuming the person knows more than they do.

One thing that often trips me up is that while styles come over to iOS from Mac, the default text formatting (the one you set in Mac Scrivener Preferences) does NOT. I’ll set up my Writing Font of the Quarter on the Mac, then be happily typing along on my iPad, start a new doc and whammo! Last quarter’s font.

You can change the default formatting for new docs in iOS in much the same way, philosophically, that you do on the Mac: Select some text that has the right formatting, tap the paintbrush, and then tap on “Formatting options” in the Style menu. In the submenu that pops up, tap “Set Default Formatting.“ I wish I could always remember to do it… :wink:

NP :smiley:

I’ll try and remember it too - thanks again for the tips!