Custom Text separator not saved in Compile Format presets

With Scrivener 2.5 if I change the text separator in a custom compile format, when I reload that format the previous custom text separator is there.

Example: I was creating a new format AsciiDoc based on a previous text format. So I changed the custom text selector from a # to nothing.
Screen Shot 2013-10-26 at 11.38.20 AM.png

Screen Shot 2013-10-26 at 11.38.41 AM.png

Then I pull down on Format As and select Manage Compile Format Presets, followed by clicking Update

This change is not saved to the Format I am defining. Every time I compile, the hash mark is back. I have to delete it every time I recompile.

AFAIK all other Format changes are saved. Only this one seems to be left out.

One more thing: every time I compile the Format As switches to Custom. Why doesn’t it retain the custom format I had chosen last time? However, that has no effect on this bug: both the custom and my AsciiDoc format have the hash mark in them. It won’t go away…

If you make any changes to the Compile settings, they change to “Custom” because they no longer match any presets.

Regarding the separator, have you made sure to hit Enter before re-saving the Compile format? If the focus is in the separator text field, then the edit hasn’t been committed yet - you need to hit return or enter or just click outside of the text field to end editing.

Yes, understood. But when I change the settings and then save them as per the image above – they are now their own preset. So when I click “Compile” and it says “AsciiDoc”… then I go File->Compile and it says “Custom” without me having changed anything in between. It loses sense that the settings have no changed since I last compiled using a Preset.

Yes. I know you deal with a lot of ‘users’, but I’ve been a geek for 29 years. I have my grey hair with cause. I’m not going to report something so stupid to you.

I have found a workaround of using a Single Return for now, but there are some formats where an extra line will be rendered.

Screen Shot 2013-10-27 at 1.01.40 PM.png

I cannot reproduce this. Could you give steps to reproduce? The “Format As” description won’t update until you close and reopen Compile, so as you make changes, it won’t switch to “Custom”. But if you then save those changes (either by compiling or by holding the Option key down and clicking “Save”), then the next time you open Compile it will say “Custom”.

Okay, I see what you mean now and have fixed it for a future version. However, I’m not sure why, if you want a blank separator, you would not use “Single return” or “Empty line” instead. Using a custom separator creates a separator of the format newline-separator-newline. So if you leave the custom separator blank, you end up with newline-newline - which is exactly what “Empty line” does.

Sounds to me like you are reproducing it. Here, let me phrase it as a User Story (if you like Agile terminology): “As a User, if I compile a document using a preset AsciiDoc, when I return to compile it again I want the comfort of knowing that I am still using my preset AsciiDoc, and have not diverged from it in some way I don’t understand.”

In short, if I compiled using AsciiDoc preset, and I return to compile again I want it to reflect AsciiDoc so that I know I’m compiling the same way. The current behavior shows me “Custom” even though the settings are that of “AsciiDoc”. It makes me insecure :slight_smile:

AsciiDoc is a text system in which whitespace is significant. A blank line is going to be represented in the final document. I need the separator to be Nothing, Null. Not an Empty Line which is the creation of a new paragraph for AsciiDoc. I suspect it is also that for MultiMarkdown too.

Thanks for responding so quickly, and sorry to bother you with requests that won’t matter to a vast majority of your audience.

If my description is what you are doing, then the behaviour is as expected.

But you’re not still using AsciiDoc if you have made changes to it. I’ve you’ve loaded the AsciiDoc format, or if you’ve just updated it via the presets manager panel, and then you subsequently make changes to the current Compile settings, then they no longer match the AsciiDoc format settings. Thus, it will say “Custom” the next time you open it if you save those settings into the project, because they are indeed custom settings that no longer match any presets.

But leaving the separator empty will have exactly the same result as choosing “Empty Line”. There is no difference at all between choosing “Custom” and leaving the text field blank and choosing “Empty Line”. So I still don’t understand what choosing “Custom” is going to achieve if you are leaving the text field blank.

Okay, this is where we are missing each other. I choose AsciiDoc. I make a change and save it back to the Preset, as the images I put in my post show. I make no changes other than to output the compiled document. I re-enter Compile mode and it says Custom.

Okay, I misunderstood “Empty Line” to be “\n”. That’s a line with nothing in it. You are saying that Empty Line is “not a line” so that confused me. But it works for me :slight_smile:

Yes, it’s an “empty line” as in there will be an empty line placed between paragraphs. Although “Single newline” and “Double newline” would be more accurate to me, it’s a bit geek-speak for most. :slight_smile: