Custom words list, thousands of words, Found bug

I tried the demo and wanted to add around 5600 transliterations in scrivener for research purpose. However, the tool in options>corrections>spelling>view personal word list only adds one word.

I tried another method where I pasted all the words in text area then started adding them to dictionary but then it will take thousands of mouse clicks. I also found that custom words are not added to hunspell en-us dic. It means they are somewhere else. I can buy the software if I can solve this matter.

I need a way to add those words because without them it will create red lines under each word I write.

On more research I found that though the custom word list added to scrivener is corrected, it never shows the suggestions, when we retype the similar word. It is happening with all words.
For example I correct Ajita to Ajitā. Now when I write Ajita then it never shows the corrected word
in suggestions. It is happening with all the words.

The answer to your questions is dependent on your OS.

I cannot tell from your post or your profile: are you on Windows or Mac?


In Windows, I was able to do it efficiently like this:

  • Have all your words on a line of their own in an otherwise blank document. (If they are not each their own paragraph - so, separated by a carriage return -, have Scrivener replace spaces for carriage returns for that document.)

  • Once that is done and that you have something that looks like this:
    click after the first letter of the topmost word, then use the following shortcut sequence:

  • Win+Alt+; (Learn spelling)

  • Down arrow.

Repeat those two shortcuts over and over until you reach the bottom of your document.

Fastest way to do it that I could think of. Shouldn’t take you all that long.
(Once you get the hang of it, you can do a couple words per second.)
Perhaps on Mac you could even program yourself a one key macro. (?)

If there is a way to paste them directly in image , I don’t know how, and couldn’t make it work.

I actually managed to make it work :slight_smile:
It works, but only with words for which none of the letters have an accent. (Such as é, à, and the likes.)
You need in a Scrivener document to have all of your words in a single paragraph, separated like this:
word, word, word
Then you copy this at the end of the “[General]” section (the top one) of image.

Where is that word list file?


→ Could be a good idea to make a copy of your wordslists.ini file elsewhere before tweaking it. In case things get messed up.

→ Note the space before the very first word. You need that.




Save the wordlists.ini file. Restart Scrivener.


That’s the best I could do. I suppose that for words with accents, if any, you’d have to do them the way I first described in the top half of this post. Meaning, manually.
(Unless there exists a more convenient way, that is.)


If the OP is on Windows, I suggest they try editing the Hunspell dictionary to add their custom words, using the technique described in this post. Of course, first make a backup of the dictionary, in case it breaks.


1 Like

Link missing ? Which post, my friend ?
If you meant mine, I am afraid editing the Hunspell dictionary is a tad (or way) more complicated than that.
I believe @AntoniDol knows the how to of it, and could confirm or infirm that.

Thanks, @Vincent_Vincent fixed it!

Yes, it might be.

1 Like

Sorry My bad. It is windows OS.

It is always a good idea to put it in your profile.
If you click on my icon, you’ll see I am a Windows user too.

I was able to do it using the method I mentioned but then scrivener does not recognize the words in suggestions. On right click the words suggested are no where the word to place.

I feel that the diacritics are not understood by scrivener and there is definitely some issue in this matter. If we give suggestions then there will be thousands of suggestions. If we use autocorrection then wrong words are pasted. I am using IAST standardized words for sanskrit. Though I was able to add these diacritics but they are not understood by scrivener. So eventually I have to write the word with its IAST replacement which is very difficult and almost impossible. The same thing is very easy in word. I am using that currently to write and faced zero issues so far. Infact the dictionary words I used in scrivener were created by me in word over the past four years.

In the example below first five words are added to dictionary. Now on top line when I am writing ajita then the suggestions shows " ajit? " (like this). While the correct word ajitā is already there in personal word list.

Not clear why you’d need it as a suggestion, but perhaps in this case you could rather use auto-complete.

Sorry I was not clear. This is necessary because there are thousands of them. Either I use a separate editor to convert each word to IAST format then paste that or I can use the suggested words from list which scrivener is not doing. Like in word when you type a similar word, the IAST counterpart is visible because I added it to dictionary. One thing I understood by looking at files is that though IAST words are added to dictionary the format of diacritics is not understandable to scrivener. Hence it is putting question marks on exact alphabets. The word is there in dictionary but not recognizable in original format. There is some problem with how these words are added to dictionary in Unicode or ansi format. (May be I am not sure)

I would go to Project/Project Settings and see if you can add them properly to this list:


If so, with the proper options setting, Scrivener could suggest them spelled right as you type the first letters of them in the editor.

1 Like

Found a workaround which may help others. The default eng dictionary which is US has got certain format which will not allow diacritics. If I use Hindi dictionary (with added diacritics words directly in dic file) then it will not acknowledge english words and I may commit errors somewhere in the long research.

So i downloaded the English-en-gb then added my diacritic dictionary words directly in it and it saved it without warnings (not in case of American dictionary). Now it is working.

1 Like

Thanks for all the help

1 Like